Dismiss Notice



Register Today It's free! This box will disappear once registered!

Hey Guys!

Discussion in 'New Member Introductions' started by mrsddawg, July 23, 2011.

  • Searches ExplorerForum.com
    1. mrsddawg

      mrsddawg New Member

      Joined:
      July 23, 2011
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Des Moines Ia
      Year, Model & Trim Level:
      98 explorer sport
      Hi, I have a question for everyone out there. I have an older model-98 Ford explorer sport. My problem is my engine liught went on and got it checked. They told me it was a cam sensor. My question is this, I have an over head cam, and I would think I need two sensors, but the shop says I just need one, also where are they located? My brother will fix it for me but not sure when they/it is located. Any infor would be much appreciated!!

      Thank you
      Mrsddawg
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. BrooklynBay

      BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      52,815
      Likes Received:
      296
      Trophy Points:
      113
      City, State:
      Brooklyn, NY
      Year, Model & Trim Level:
      88 89 93 95 96 Aerostars
      Welcome to this forum! Do you know the exact code number?
       

    Share This Page







    We Support Our Troops!