Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

idle issues on my 94

Discussion in 'Stock 1991 - 1994 Explorers' started by DonnieFB, March 23, 2019.

^^Searches ExplorerForum.com^^





  1. DonnieFB

    DonnieFB Elite Explorer

    Joined:
    August 4, 2013
    Messages:
    20
    Likes Received:
    4
    Trophy Points:
    3
    City, State:
    S. Chesterfield, Virginia
    Year, Model & Trim Level:
    1994 Explorer
    my 94 XLT started running terrible. I pulled codes 121, 337, 558, 157, 158 and 416. I don't understand what controls these things .I just had the plugs and wires changed. I have also replaced the EGR valve, EGR Solenoid, EGR pressure feedbck sensor, PCV valve, TPS, IAC valve and a couple of vacuum lines. The idle goes up and down when the IAC is connected. When I disconnect it, the idle goes down and will cut off the car. or just idles low. Don't know what causes the low voltage readings on these codes etc.Can't spend much more on this. Any ideas would be welcome. Thanks
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. 974X4BLACKSPORT

    974X4BLACKSPORT Active Member

    Joined:
    May 21, 2018
    Messages:
    786
    Likes Received:
    162
    Trophy Points:
    53
    Location:
    FL
    City, State:
    hudson
    Year, Model & Trim Level:
    BLACK 1997 SPORT 4 BY 4
    How many miles does the XLT have? Has the throttle body ever been cleaned? The ports for the IAC get clogged and restricts the air causing poor idle. How does the engine respond in the 1500-3500 RPM ranges?
     
  4. DonnieFB

    DonnieFB Elite Explorer

    Joined:
    August 4, 2013
    Messages:
    20
    Likes Received:
    4
    Trophy Points:
    3
    City, State:
    S. Chesterfield, Virginia
    Year, Model & Trim Level:
    1994 Explorer
    It has about 215000 miles,
    I have cleaned the throttle body with spray cleaner several times. It goes up and down in the 1500 - 3000 range. If I unplug the IAC it was running better but now if I do it it seems to bog down and cut off
     
  5. FR-425

    FR-425 Used to be a road here. Elite Explorer

    Joined:
    November 21, 2013
    Messages:
    2,655
    Media:
    1
    Likes Received:
    95
    Trophy Points:
    68
    City, State:
    Phoenix, AZ.
    Year, Model & Trim Level:
    1994 Explorer Limited
    High voltage across so many different systems would indicate an open circuit.

    Low voltage would indicate a short.

    You likely have a broken, worn through, rodent chewed, wire that is intermittently shorting on something.
     
  6. DonnieFB

    DonnieFB Elite Explorer

    Joined:
    August 4, 2013
    Messages:
    20
    Likes Received:
    4
    Trophy Points:
    3
    City, State:
    S. Chesterfield, Virginia
    Year, Model & Trim Level:
    1994 Explorer
    Thanks I will look it over some more. Just trying to get an idea and direction to go.
     

Share This Page







We Support Our Troops!