Dismiss Notice



Register Today It's free! This box will disappear once registered!

Intermittent blinking of the O/D off light.

Discussion in 'Stock 1995 - 2001 Explorers' started by cramer67pony, July 7, 2011.

  • Searches ExplorerForum.com
    1. cramer67pony

      cramer67pony New Member

      Joined:
      July 7, 2011
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Lake Arrowhead, Ca.
      Year, Model & Trim Level:
      1997 XLT 4x2
      Hello all.
      I am looking for some advice. I have a 1997 explorer XLT 4x2. I am getting an interittent blinking O/D off light. Haven't had the codes pulled yet. However the trans seems to be working fine. It shifts in and out of O/D correctly whether the light is blinking or not. No surges or anything. RPM's & MPH read correctly all the time. When the light does come on it is after 10-15 minutes or so. Any suggesttions on what this could be?

      Thanks, Clark.
       
      Last edited: July 7, 2011
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. BrooklynBay

      BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      52,498
      Likes Received:
      248
      Trophy Points:
      93
      City, State:
      Brooklyn, NY
      Year, Model & Trim Level:
      88 89 93 95 96 Aerostars
    4. drdoom

      drdoom Well-Known Member

      Joined:
      December 13, 2007
      Messages:
      4,079
      Likes Received:
      76
      Trophy Points:
      68
      City, State:
      VA
      Year, Model & Trim Level:
      2005 Eddie Bauer 4.6L 4X4
      Not much to go on without the codes, but my wild guess would be a Torque Converter Clutch System fault. YMMV
       

    Share This Page







    We Support Our Troops!