1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

iOS Mail email notification hyperlink problem

Discussion in 'Suggestion Box - Forum Feedback' started by BonesDT, July 22, 2011.

^^Searches ExplorerForum.com^^





  1. BonesDT

    BonesDT Elite Explorer

    Joined:
    July 12, 2002
    Messages:
    1,084
    Likes Received:
    3
    Trophy Points:
    48
    City, State:
    Westchester, NY
    Year, Model & Trim Level:
    Red '99 Sport SOHC 4x4
    This is what I've been getting when I use the built in Mail apps on both my iPhone and iPad:

    This thread is located at:
    http://www.explorerforum.com/forums/showthread.php?t4211&goto=newpost

    There are two problems with this. First, it only hyperlinks up to the ".php" and gets cut off from the "?" on. Second, even weirder, the true link is suppose to be ".php?t=174211&goto". It deletes the "=17" from the link, so I can't even copy and paste the entire link into a browser.

    The same email shows the proper link on my MacBook mail app and when I log onto Gmail through Safari on my iPad (as opposed to using the built in Mail app) the link is OK too. So it is clearly some issue with the iOS Mail app. I haven't yet tested to see if it is exclusive to Gmail though. I'll try switching my notification email address to see.

    Here's another one:

    This thread is located at:
    http://www.explorerforum.com/forums/showthread.php?t"6450&goto=newpost

    I thought maybe there was some coding issue with the "?" causing the Mail app to want to cut the hyperlink underlining off before it, but this email hyperlinked the "?t" as well then cuts of the rest.

    This link was suppose to read ".php?t=226450&goto", so in this example it deletes the "=22", but this time replaces it with a quotation mark.

    Very odd. Is this happening on everyone else's iDevices?
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. BonesDT

    BonesDT Elite Explorer

    Joined:
    July 12, 2002
    Messages:
    1,084
    Likes Received:
    3
    Trophy Points:
    48
    City, State:
    Westchester, NY
    Year, Model & Trim Level:
    Red '99 Sport SOHC 4x4
    Also, I tried creating a new email, then I manually typed one of the links in the email, and then without actually creating a hyperlink, I sent it off. I then checked my iPad and the link appeared hyperlinked and correct. So it also seems to have something to do with receiving the emails from ExplorerForum.

    Edit: Also, the initial email from ExplorerForum, the one that is received screwed up on my iPad but correct on my laptop - if I forward the email to myself, the forward then appears correct on the iPad. So for some reason it is not liking the initial email from ExplorerForum.
     
  4. BonesDT

    BonesDT Elite Explorer

    Joined:
    July 12, 2002
    Messages:
    1,084
    Likes Received:
    3
    Trophy Points:
    48
    City, State:
    Westchester, NY
    Year, Model & Trim Level:
    Red '99 Sport SOHC 4x4
    Bump, still happening. No one else has experienced this??
     
  5. Rick

    Rick Pumpkin Pilot Staff Member Admin Elite Explorer

    Joined:
    February 8, 1999
    Messages:
    31,370
    Media:
    43
    Albums:
    4
    Likes Received:
    725
    Trophy Points:
    143
    City, State:
    Wayoutin, Aridzona
    Year, Model & Trim Level:
    '93 XL Pumpkin Edition
    Callsign:
    AB7FH
    No one else has reported this. The initial email is straight HTML. Just the most basic tags.:dunno:
     
  6. Maniak

    Maniak Moderator-Stock 91-94 Staff Member Moderator Elite Explorer

    Joined:
    February 9, 1999
    Messages:
    12,109
    Media:
    1
    Likes Received:
    83
    Trophy Points:
    68
    City, State:
    Vail, Arizona
    Year, Model & Trim Level:
    1992 XLT 4x4
    Email links are coming in fine on my iphone..

    Its a 3gs, running 4.01 IOS (was running 3.12 until last week).

    My built in mail app is linked to a gmail apps account.

    I wonder if its actually not the IOS, but the mail server that is doing that (like gmail or hotmail etc).

    ~Mark
     






We Support Our Troops!