1. Register Today It's free! This box and some ads will disappear once registered!

    Dismiss Notice

Just heat

Discussion in 'Stock 2002 - 2005 Explorers' started by Doug 66, May 18, 2014.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information


  1. Doug 66

    Doug 66 New Member

    Joined:
    February 20, 2012
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    hudson ill.
    Year, Model & Trim Level:
    2002 explorer
    I have an 02 explorer and all I get is heat out of the vents . Ive opened the glove box door and saw the actuaters working and moving the blend door ,so I have no idea what the problem is.
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. BigRondo

    BigRondo USMC 1371 Elite Explorer Moderator Emeritus

    Joined:
    February 15, 2010
    Messages:
    7,886
    Likes Received:
    10
    Trophy Points:
    48
    City, State:
    Worcester, MA
    Year, Model & Trim Level:
    2002 XLT V6 4x4
    Do you here any clicking behind the dash when you change the Temp Control Knob?

    Do you have manual or automatic climate control?
     
  4. Doug 66

    Doug 66 New Member

    Joined:
    February 20, 2012
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    hudson ill.
    Year, Model & Trim Level:
    2002 explorer
    I have manual controls with no clicking behind the temp control knob. I do have the clicking in the back of the truck though
     
  5. Exproblems

    Exproblems Well-Known Member

    Joined:
    April 17, 2011
    Messages:
    1,687
    Likes Received:
    7
    Trophy Points:
    48
    City, State:
    Orchard Park, N.Y.
    Year, Model & Trim Level:
    '05 Explorer XLT 4.0L
    Do you have "rear heat" along with temp controls for the rear seats? If you do, you could have a bad"rear blend door actuator" for the rear heat, even though the front blend door actuator is working fine. The clicking noise you hear is usually from a bad blend door actuator. There are past posts in here on how to replace the rear blend door actuator as well as the front one. Just use the search box at the top of the forum and type a question related to that issue into the box and include your year Explorer and engine size into the question. The system will pull up past posts according to what you type into your question.
     

Share This Page







We Support Our Troops!