Dismiss Notice



Register Today It's free! This box will disappear once registered!

Knocking from passenger valve cover!!

Discussion in 'Modified 2002 - 2005 Explorers' started by sporttractuner, August 20, 2011.

^^Searches ExplorerForum.com^^





  1. sporttractuner

    sporttractuner Member

    Joined:
    December 7, 2006
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Edmonton, AB
    Year, Model & Trim Level:
    2003 sporttrac XLT
    For the past six or so months, I have been getting a cylinder 2 misfire code, along with a random cylinder misfire. My trac still seamed to be running ok, with an occational rough idle. about a month ago, I startedd my truck, and it started making a terrible knocking/tapping comming from the passenger side valve cover.(not to be mistaken for the timeing chain rattle. it's been doing that for years). I've been forced to buy a new truck, so this is no longer my daily, but I need to get it running, so i can sell. it still starts, and sounds horrible, but after warming up, the noise goes away until you apply throttle. I have pulled the oil pan, and made sure that there was no debris in the bottom end. so this morning I pulled off the valve cover. as far as i can tell, the springs look in good shape. one of the lodes on the cam(cylinder 2) is pretty rough, and there are some definite metal shavings in the area. Could this be the cause of the problem? can the cam be machined, or replaced? what are my options her, and what else should i be looking for?

    Thanks in advance guys, i'm in way over my head here...

    Dave
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. John Frank

    John Frank New Member

    Joined:
    December 20, 2006
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Sydney NSW
    Year, Model & Trim Level:
    '00 Explorer 4WD Ltd SOHC
    Hi, Can't really help, but just a bump on your question.

    What sort of engine do you have? might help others help you with info.
     
  4. swetrid

    swetrid Well-Known Member

    Joined:
    September 30, 2010
    Messages:
    1,891
    Likes Received:
    3
    Trophy Points:
    0
    City, State:
    Reading Pa
    Year, Model & Trim Level:
    1999 Eddie Bauer
    Has to be 4.0L as that is only engine option for 03 Sport trac. Could have broken valve spring or roller follower concern.
     
  5. gamecocks

    gamecocks Active Member

    Joined:
    November 23, 2010
    Messages:
    267
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Greenville, SC
    Year, Model & Trim Level:
    2002 Eddie Bauer
    i have a bent connecting rod (or so i think) cheapest bet is to swap the motor
     

Share This Page







We Support Our Troops!