Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

List of issues please help

Discussion in 'Stock 1995 - 2001 Explorers' started by calvinglen, January 28, 2014.

^^Searches ExplorerForum.com^^





  1. calvinglen

    calvinglen New Member

    Joined:
    January 28, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Oklahoma City
    Year, Model & Trim Level:
    1996 limited 4.0L V6
    Hello everyone I have a few issues with my explorer and I was wondering if I could get some help.
    I have a 1996 limited edition 4.0L 4wd V6 pearl(?) explorer.
    The first and main problem is electrical related. When I turn on my lights the parking lights come on but nothing else. I can you my brights and that works just fine and it looks the same as when my lights use to work but the headlight casing itself is pretty gummed up from years of outdoor weather so my brights might just look like my headlights. If you have any idea let me know.
    The second problem is the ac compressor, when I hit automatic or any other button besides vent on the temperature control panel the car shakes a bit and seems to lose a lot of power, I have since only used the vent button. I checked the pulley for the ac compressor and it still turns just fine so it's not locked up or anything. Any ideas please let me know.
    The third issue I have is that the driver side window is extremely slow to roll down and it needs two or three clicks to actually come all the way down. I checked the connection in the door and it's all connected so it should work. I had the entire motor for the window replaced in the last 2 years as well. I'm kinda stuck on this one. Please help.
    Last issue that is of concern. I had a blow out not too long ago and my driver side rear tire took of a bit of what I think is the running board or the rear quarter panel. Not the truck looks a bit odd with the wheel base showing. If you know what this piece is called or where to order one please let me know!
    Thanks! I know this is a lot, the help is as always greatly appreciated
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. JimMadsen

    JimMadsen Active Member

    Joined:
    April 1, 2012
    Messages:
    230
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    New Britain, CT
    Year, Model & Trim Level:
    2000 Mercury Mountaineer
    Lights:
    Have you tried replacing the bulbs or checking the fuse?

    Window:
    Grab some silicone spray and hit the rubber tracks around the window. Roll up and down a few times and if everything is good, will start working again. Otherwise you need to open the door up and re-attach the plastic clips. The silicone fixed mine up great.

    Body damage:
    Can you post a picture?
     
  4. albi1cnobi1

    albi1cnobi1 Elite Mountaineer Elite Explorer

    Joined:
    December 21, 2007
    Messages:
    1,799
    Likes Received:
    5
    Trophy Points:
    48
    City, State:
    South Jersey
    Year, Model & Trim Level:
    99 Mountaineer V6 4x4
    If it's a Limited it probably has the LOM(lights out module). When this module goes bad doesn't it cause the head lights to stop working?(I don't have this so not sure, just what I've read on the forum)
     
  5. my98nnj

    my98nnj Well-Known Member

    Joined:
    September 27, 2008
    Messages:
    1,636
    Likes Received:
    4
    Trophy Points:
    0
    City, State:
    Boonton, New Jersey
    Year, Model & Trim Level:
    1998 XLT
    A/C Compressor:

    The A/C compressor will run on any setting except for VENT. This is to dehumidify the incoming air which keeps the interior windows clear.

    The loss of power is from the draw on the engine. The engine shouldn't shake, is the compressor running OK? Is the idle speed dropping down to low when this happens?
     
  6. bobflood

    bobflood Elite Explorer

    Joined:
    May 27, 2010
    Messages:
    1,577
    Likes Received:
    22
    Trophy Points:
    48
    City, State:
    Powder Springs, GA
    Year, Model & Trim Level:
    1997 Eddie Bauer V8 2WD
    How are you checking the AC compressor? If you are just turning by hand and calling it good, that is not a valid test as the clutch would be disengaged. Test with the engine running. Good luck.
     

Share This Page







We Support Our Troops!