Dismiss Notice



Register Today It's free! This box will disappear once registered!

Loose steering issues

Discussion in 'Modified 1995-2001 Explorers' started by BullFish, June 18, 2011.

  • Searches ExplorerForum.com
    1. BullFish

      BullFish New Member

      Joined:
      June 17, 2011
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Brighton, Michigan
      Year, Model & Trim Level:
      '00 Sport 4x4
      Hey Guys! Wondering if anyone has any input on my problem. The steering is loose on my 2001 Explorer Sport 4x4. Let me tell you its lifted 4 suspension, 3 body, on 35 TSL's. I rebuilt the entire front end last year which included a new rack, tie rods (inner and outer), ball joints (upper and lower). The problem looks to be that the steering shaft is moving quite a bit in an arc as it passes thru the firewall. I cannot see a bushing there, but that seems to be where all of my slack is coming from. Am I crazy, or is there something at the firewall that is supposed to support the steering shaft itself?

      Thanks guys, I love my truck and the family loves to wheeling with me. Just want to make it a bit more driveable.

      Fish
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Texan01

      Texan01 Active Member

      Joined:
      November 16, 2001
      Messages:
      737
      Likes Received:
      0
      Trophy Points:
      16
      City, State:
      Dallas, TX
      Year, Model & Trim Level:
      1995 Explorer XLT
      There's no center support for the shaft. Most likely the looseness is in the lower shaft where it bolts to the rack. It just rides through the boot there.

      My '95 had the same problem, and I just swapped in a complete 2003 Sport assembly in. no more slack in the steering, even with nearly 300k on the factory rack.
       

    Share This Page







    We Support Our Troops!