Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Low Oil pressure light on Help a newbie

Discussion in 'Stock 2002 - 2005 Explorers' started by fordlover453, June 29, 2012.

^^Searches ExplorerForum.com^^



Do Not Sell My Personal Information



  1. fordlover453

    fordlover453 New Member

    Joined:
    June 25, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    0
    Hey guys I just picked up an 02 ford explorer v8 last week and I swear on the test drive there was no low oil pressure light but when I went to go start the car the next morning the little gauge was blinking low oil pressure/oil change required. The engine doesn't ping, knock, or make any noises at all. The oil level is completely fine and the engine runs smooth with 78k. I bought an oil pressure sending unit and am going to be installing it today but I am wondering, if for whatever reason the problem doesn't go away with the sending unit, what are my next steps. What is worst case scenario that could be wrong?
     
  2. Support EF

    Join the Elite Explorers for $20.

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. jayton

    jayton Active Member

    Joined:
    October 26, 2006
    Messages:
    148
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    Jefferson, GA
    Year, Model & Trim Level:
    02 XLT V8
    Was it the oil pressure switch? What ended up happening?


    I have a feeling that you already know the answer to this question. The low oil pressure light is the "death light."
     
  4. fordlover453

    fordlover453 New Member

    Joined:
    June 25, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    0
    well i realized the light only comes on if i put the key to the first position. then it goes away when i start it...really weird
     
  5. FordFool2

    FordFool2 Active Member

    Joined:
    December 11, 2010
    Messages:
    402
    Likes Received:
    1
    Trophy Points:
    16
    City, State:
    Cedar Rapids, IA
    Year, Model & Trim Level:
    04 Eddie Bauer & 13 Ltd
    Nothing weird about that conditional at all. The vehicle is trying to tell you, through the idiot light, that with the key in RUN position, the engine is failing to make enough oil pressure.
     
  6. fordlover453

    fordlover453 New Member

    Joined:
    June 25, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    0
    haha im used to european cars. this explorer is my first domestic car and on all the european cars i've owned, it doesn't come up with lights like that or messages that would potential mess up my day lol
     

Share This Page







We Support Our Troops!