1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

M90 rebuild (rudy)

Discussion in 'Need for Speed!' started by jd4242, March 30, 2013.

^^Searches ExplorerForum.com^^





  1. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    No major running issues so far..i am getting alot of heat soak from the charger,even though i haven't gotten in to boost at all..its running pretty warm,about 150* after charger..it stays around that temp after awile of driving,i am spinning the piss outa this charger..this makes me very nervous for wot boost pulls..

    Ive ordered a fan for my front mount cooler hoping that will help,think i may need to add a reservoir tank..

    I do have a slight vibration which im pretty sure is my pinion angle,im gonna call the driveshaft shop and see if they can check my angles and double check the balance on the shaft..he did not balance it,said ""they come out within spec but if i have issues bring it back and he will balance to a tighter spec"" welllllll should've done that first but also can very well be my angles,i did drop the trans about a inch with the solid mount..

    Tuner got back to me and my dyno adjust is friday the 13th.!!! Yeaaaa i know!! Still got about 200 miles to go and I'll be changing from e50 to e85 before the dyno in hopes of helping with temps..
     
    Last edited: October 6, 2017
    • Like Like x 1
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. Awon2zip

    Awon2zip Elite Explorer

    Joined:
    November 9, 2014
    Messages:
    209
    Likes Received:
    48
    Trophy Points:
    38
    City, State:
    Denver, Colorado
    Year, Model & Trim Level:
    1994 Ford Explorer Sport
    Can't wait to see some dyno numbers
     
    • Like Like x 2
  4. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    Me either. .think they are gonna be little lower than what i was anticipating..i know not running the roller rockers i gave up a pretty substantial amount of lift and horsepower..

    Also i anticipated this new cooler keeping it much cooler or should say didnt think i would see such a huge jump in temps from over spinng this thing,so thats going to equal probably less timing than im currently running. .but idk going to e85 should help,there is people in Australia that are running this same pulley combo seeing 20ish lbs,over 280* IAT,with no intercooler and on e85...they are crazy down there tho!!

    Ill be happy in the 400s on boost alone but might be alot to ask now,we shall see..the big numbers are going to come from nitrous. .that will lower my temps and ill make huge power off that..im also not going to spray this motor till my aviator is fixed and im also not releasing those numbers..
     
    Last edited: October 6, 2017
  5. boominXplorer

    boominXplorer Elite Ranger Elite Explorer

    Joined:
    September 16, 2002
    Messages:
    8,801
    Media:
    55
    Albums:
    3
    Likes Received:
    473
    Trophy Points:
    103
    City, State:
    Virginia Beach, Va
    Year, Model & Trim Level:
    00 4x4 Mounty
    Vibrations with completely solid mounts? How could that be? Haha
     
    • Like Like x 1
  6. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    Bahahahaha o yea the truck rocks like crazy now!! But this vibration is drivetrain related for sure..lol
     
  7. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    Dnyo day has changed to this Thursday the 12 at 9:30..he has to go out of town Friday. .

    Dont think my IC radiator fan will be in time to install it though and i still got about 200 miles for clutch to break in
     
  8. 4pointslow

    4pointslow Explorer Torture Tester Elite Explorer

    Joined:
    April 3, 2008
    Messages:
    2,832
    Likes Received:
    345
    Trophy Points:
    103
    City, State:
    Gloucester City, NJ
    Year, Model & Trim Level:
    98 2Dr,98 & 04 4dr xlt
    Better get driving then! lol
    Good luck on dyno day!
     
    • Like Like x 1
  9. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    Truck is at the drives shaft shop..Tranny is 3* off and the drives shaft is WAAYYY out a balance. .

    not to happy about drives shaft as the guy who made it was paid to balance it and didnt..

    Hopefully this fixes this issue. ..75miles to go!!
     
    Last edited: October 11, 2017
  10. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    Well that fixed it to the cost of $289!!!! NOT HAPPY...

    Changed oil,looked good no flakes or anything...stuck some BR6EF plugs in and double checked everything. .40miles to go..

    got a feeling when I go back for the nitrous tune and have my fan on my IC I'll make much more power but we will see...

    WISH ME LUCK!!!
     
    • Like Like x 1
  11. Awon2zip

    Awon2zip Elite Explorer

    Joined:
    November 9, 2014
    Messages:
    209
    Likes Received:
    48
    Trophy Points:
    38
    City, State:
    Denver, Colorado
    Year, Model & Trim Level:
    1994 Ford Explorer Sport
    I do think all these struggles will be well worth it in the end once you really get it running. Good luck!
     
    • Like Like x 1
  12. 4pointslow

    4pointslow Explorer Torture Tester Elite Explorer

    Joined:
    April 3, 2008
    Messages:
    2,832
    Likes Received:
    345
    Trophy Points:
    103
    City, State:
    Gloucester City, NJ
    Year, Model & Trim Level:
    98 2Dr,98 & 04 4dr xlt
    Good luck on the dyno day!
     
    • Like Like x 1
  13. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    Well that didn't go good....I've got fuel issue, we are pretty sure it's the regulator. .the pressure jumps around and doesn't maintain pressure at wot..

    We did 3 pulls and had to shut it down at 4400..at about 3300 it would just start leaning out and kept getting worse no matter what we tried,then we looked at the gauge for last pull and could tell the psi is messed up..

    He also suggest I swap pump to a newer pump,change the sock and the main filter..as well as the regulator. .

    But it did make 415 lbs of tq around 3500-4000 and 304 rwhp in same range @13 psi before it started leaning out and going to crap....still has 8 psi and another 3,000 rpms left, so numbers should climb ALOT...he guessed it will make low/mid 400s rwhp and low 500s for tq once it's all sorted out
     
    Last edited: August 6, 2018
    • Like Like x 1
  14. 4pointslow

    4pointslow Explorer Torture Tester Elite Explorer

    Joined:
    April 3, 2008
    Messages:
    2,832
    Likes Received:
    345
    Trophy Points:
    103
    City, State:
    Gloucester City, NJ
    Year, Model & Trim Level:
    98 2Dr,98 & 04 4dr xlt
    Those numbers sound real promising!
    Get that fuel starvation problem fixed!
     
  15. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    It's not really starving, the regulator doesn't consistently go to what it's set at..if you set the base pressure to say 60 psi it will sometimes be 60 sometimes be 70,sometimes be 80,sometimes be 43...it also isn't reacting from its boost reference...my stock fpr is keeping the pressure from dropping below stock,think 42psi at idle..but the aftermarket one is making the pressure jump all over the place when no rpm change,like at idle..the diaphragm is bad in it,its not e85 safe..

    The problem with the stock one is its vacuum reference, not boost..so it's not increasing fuel after vacuum hits 0 and I start loosing fuel pressure when boost comes in..this is where the aftermarket should increase pressure or keep it pretty close to a constant psi..

    He only wants me to change pump,sock and filter because it's been probably 5 years of ethanol running through it,as a precautionary safety net..said my choice but recommends it
     
    • Like Like x 1
  16. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    I've ordered a new 340lph TRE pump,Fuelab pressure regulator and a new main filter..i had a 300lph pump so this one is gonna flow little more..

    Hopefully this is last hiccup!! I got babies to feed!!
     
    • Like Like x 1
  17. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    Hey you have the professional products 10300 filter also right?? Think you was the one who recommended it for me..

    Ive done some more research and it uses a paper filter,many have said its not e85 safe..i guess ill be giving them a call..its been discontinued so took me forever even to find one..part #10320 or same filter a BG500 uses
     
  18. 4pointslow

    4pointslow Explorer Torture Tester Elite Explorer

    Joined:
    April 3, 2008
    Messages:
    2,832
    Likes Received:
    345
    Trophy Points:
    103
    City, State:
    Gloucester City, NJ
    Year, Model & Trim Level:
    98 2Dr,98 & 04 4dr xlt
    Not me, don't have that filter.
    I am running stock filters on all three trucks.
     
  19. Turdle

    Turdle Freelance Stuntman Staff Member Moderator Elite Explorer

    Joined:
    June 16, 2003
    Messages:
    29,025
    Likes Received:
    795
    Trophy Points:
    143
    City, State:
    Humboldt, KS
    Year, Model & Trim Level:
    2000 Mounty
    Do you think you might need a voltage driver for the pump? Just for conversation sake, could the PCM output volatge be too low for what you need to maintain pressure?
     
  20. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    O crap..hmm wonder who it was..lol guess didnt really matter was just trying to share that the filter isnt made anymore and isnt e85 safe..lol

    Think ill be switching to a different filter setup with a ss mesh thats e85 safe
     
  21. jd4242

    jd4242 Explorer Addict

    Joined:
    October 15, 2008
    Messages:
    10,821
    Likes Received:
    283
    Trophy Points:
    113
    City, State:
    va beach
    Year, Model & Trim Level:
    92explorer&94 ranger
    I dont think so,even with my old pump at 300lph and -6an lines it should support my needs..

    We honestly think its the regulator but more i dig into it, the more parts i find that were once considered ethanol safe, are not any longer..

    The old TRE 300lph pump is but ive already replaced the ss lines i had with PTFE ones,they LITERALLY melted and gas was coming out throught the SS sheathing..i should've looked at filter and regulator then also...only thing that probably prevented issues sooner was fact i was running e50..im on e85 now,was the only thing we could really tune for yesterday. .
     

Share This Page







We Support Our Troops!