Dismiss Notice



Register Today It's free! This box will disappear once registered!

M90 rebuild (rudy)

Discussion in 'Need for Speed!' started by jd4242, March 30, 2013.

  • Searches ExplorerForum.com
    1. vroomzoomboom

      vroomzoomboom Elite Canuck STOCK SUCKS! Elite Explorer

      Joined:
      January 22, 2007
      Messages:
      9,189
      Likes Received:
      510
      Trophy Points:
      133
      City, State:
      selkirk, manitoba
      Year, Model & Trim Level:
      98 supercharged 347 sport
      nooooooo!! i do stupider! why the hell would i tell you to duct tape it and send it????? you know how expensive duct tape is? never ever use duct tape when bubble gum will do!






      ......ever....
       
      • Like Like x 1
      • Useful Useful x 1
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. jd4242

      jd4242 Explorer Addict

      Joined:
      October 15, 2008
      Messages:
      10,821
      Likes Received:
      280
      Trophy Points:
      113
      City, State:
      va beach
      Year, Model & Trim Level:
      92explorer&94 ranger
      Well it still aint running right..starts up fine,runs perfect a/f for about a min or so then goes straight lean.....

      Ive got the flu and this shits REAL old!!
       
      • Like Like x 1
    4. Centaurus5.0

      Centaurus5.0 Elite Explorer

      Joined:
      April 15, 2016
      Messages:
      1,056
      Media:
      1
      Albums:
      1
      Likes Received:
      295
      Trophy Points:
      103
      Year, Model & Trim Level:
      96'
      C'mon bro, you're almost there!

      [​IMG]
       
      • Like Like x 2
    5. jd4242

      jd4242 Explorer Addict

      Joined:
      October 15, 2008
      Messages:
      10,821
      Likes Received:
      280
      Trophy Points:
      113
      City, State:
      va beach
      Year, Model & Trim Level:
      92explorer&94 ranger
      Im just wondering how long has it been leaking before it totally blew out..wondering if it was tuned with a slight leak..

      Only other thing thats different is the new O2s,unless they are bad. .i unplugged the coolant temp to try and force it into ooen loop but it didnt help any,still ran lean with a CEL on
       
      Last edited: February 5, 2018
    6. Dono

      Dono V8 Limited turbo and retired SC 4.0 OHV Elite Explorer

      Joined:
      February 18, 2009
      Messages:
      5,050
      Likes Received:
      356
      Trophy Points:
      103
      City, State:
      Winnipeg, Manitoba
      Year, Model & Trim Level:
      00 Limited V8
      If you could only log the o2's you would know. fyl. lol.
      Iv'e heard FML, but never FYL before.

      Yea, it gets old.

      I wish we were all closer together to be a support group and try to help where we can.
       
      • Like Like x 1
    7. jd4242

      jd4242 Explorer Addict

      Joined:
      October 15, 2008
      Messages:
      10,821
      Likes Received:
      280
      Trophy Points:
      113
      City, State:
      va beach
      Year, Model & Trim Level:
      92explorer&94 ranger
      Well after replacing EVERY sensor AGAIN i think i found the issue. ........

      I had my O2 banks backwards. .apparently there is spose to be one grey and one white connector, dictating which bank the O2 controls...both of mine are white..this truck had 2 O2 both pre-cat and one per y-pipe originally...

      So basically one bank was needing fuel but the O2 was adding it to wrong set of injectors which mad the other O2 read even richer which in turn was taking fuel away from the original bank needing fuel causing it to be even more lean..or something like that..seems to have ran fine for last 45 minutes in the garage. .its pouring rain here so im gonna wait till tomorrow to test drive it,plus im a couple drinks deep!!!

      Say a prayer that was the issue! !
       
      • Like Like x 2
    8. Centaurus5.0

      Centaurus5.0 Elite Explorer

      Joined:
      April 15, 2016
      Messages:
      1,056
      Media:
      1
      Albums:
      1
      Likes Received:
      295
      Trophy Points:
      103
      Year, Model & Trim Level:
      96'
      Your doing it all wrong, you need to reverse that order.

      1.Say a prayer
      2.Have a couple more drinks
      3.Go reenact Tokyo Drift in the rain for 45 minutes.

      As a friend, I'm saying, you only live once.
       
      • Like Like x 2
    9. 2000StreetRod

      2000StreetRod Staff Member Moderator Elite Explorer

      Joined:
      May 26, 2009
      Messages:
      10,552
      Likes Received:
      196
      Trophy Points:
      93
      City, State:
      Greenville, SC
      Year, Model & Trim Level:
      00 Sport FI, 03 Ltd V8
      That's a fairly common mistake but difficult to find with OBD-I. For OBD-II vehicles that are cross wired one bank will have a lean code and the other bank a rich code. My advice to find the problem easily is to disconnect one sensor and see if the O2 heater fault bank matches the one disconnected. I'm glad you found the problem!
       
      • Useful Useful x 2
      • Like Like x 1
    10. Dono

      Dono V8 Limited turbo and retired SC 4.0 OHV Elite Explorer

      Joined:
      February 18, 2009
      Messages:
      5,050
      Likes Received:
      356
      Trophy Points:
      103
      City, State:
      Winnipeg, Manitoba
      Year, Model & Trim Level:
      00 Limited V8
      Traction seems to be an issue. lol.
      Smart man to just relax and have another celebration drink.

      In our younger years we probably wouldn't have exercised good judgement.
       
      • Like Like x 2
    11. jd4242

      jd4242 Explorer Addict

      Joined:
      October 15, 2008
      Messages:
      10,821
      Likes Received:
      280
      Trophy Points:
      113
      City, State:
      va beach
      Year, Model & Trim Level:
      92explorer&94 ranger
      Haha my girl came out to garage(given its a detached and had main door cracked about a foot and windows open) to see me sitn on a stool,smoking cigarettes and drinking a mixed drink with the truck running...

      See goes """awwww shit you've given up and committing suicide aren't you???"""hahah i said YEEEPPPPP and told her to leave me be!!!
       
      • Like Like x 2
    12. jd4242

      jd4242 Explorer Addict

      Joined:
      October 15, 2008
      Messages:
      10,821
      Likes Received:
      280
      Trophy Points:
      113
      City, State:
      va beach
      Year, Model & Trim Level:
      92explorer&94 ranger
      Kinda the way i found out,i unplugged each one at a time and it made it rich or lean...then pulled plugs and could tell that side was not rich or lean..3 sets of plugs,4 O2s,1 coolant sensor, 1 tps and 1 crank sensor i decided to swap banks to see if it effected the opposite bank and sure as hell it did..

      O also unplugging the O2 does not throw a cel,it may throw a non cel code but other than a paper clip method i dont have a way of seeing them
       
      • Like Like x 1
    13. Centaurus5.0

      Centaurus5.0 Elite Explorer

      Joined:
      April 15, 2016
      Messages:
      1,056
      Media:
      1
      Albums:
      1
      Likes Received:
      295
      Trophy Points:
      103
      Year, Model & Trim Level:
      96'
       
    14. CDW6212R

      CDW6212R Hauls the mail. Elite Explorer

      Joined:
      June 17, 2004
      Messages:
      18,645
      Media:
      5
      Albums:
      1
      Likes Received:
      869
      Trophy Points:
      143
      City, State:
      Knoxville, TN
      Year, Model & Trim Level:
      98 Limited AWD
      Good, great to hear. Sorry it was a lot of stress, stuff happens no matter what.

      Some drinks are good, but do it at home, you also only die once.:chug:o_O
       
    15. jd4242

      jd4242 Explorer Addict

      Joined:
      October 15, 2008
      Messages:
      10,821
      Likes Received:
      280
      Trophy Points:
      113
      City, State:
      va beach
      Year, Model & Trim Level:
      92explorer&94 ranger
      Well it appears to be fixed,been running last couple days with no issues. .going to give it awile and try to head back to dyno for final tune
       
      • Like Like x 4
    16. jd4242

      jd4242 Explorer Addict

      Joined:
      October 15, 2008
      Messages:
      10,821
      Likes Received:
      280
      Trophy Points:
      113
      City, State:
      va beach
      Year, Model & Trim Level:
      92explorer&94 ranger
      Well didnt take long......

      Blew 2nd gear to pieces tonight ...was in 2nd then went WOT,once boost came in it began to spin and hope...then POWWWW!!! Sounded like a bomb went off..definitely the loudest one ive heard,we thought for sure it came through the floor...drove 3 miles in 3rd home and sounded like rocks bouncing around in the case..

      Its getting parked till i fix the aviator
       
    17. CDW6212R

      CDW6212R Hauls the mail. Elite Explorer

      Joined:
      June 17, 2004
      Messages:
      18,645
      Media:
      5
      Albums:
      1
      Likes Received:
      869
      Trophy Points:
      143
      City, State:
      Knoxville, TN
      Year, Model & Trim Level:
      98 Limited AWD
      Sorry about that, take it easy and see what it is later.
       
    18. jd4242

      jd4242 Explorer Addict

      Joined:
      October 15, 2008
      Messages:
      10,821
      Likes Received:
      280
      Trophy Points:
      113
      City, State:
      va beach
      Year, Model & Trim Level:
      92explorer&94 ranger
      Its destroyed now for sure..ive been talking to Astro about their A5 kit,it uses a different input shaft than i have..they do make the correct input shaft but is for the aussie's falcon t5 which is same trans as im using..BUT they haven't made any in over a year and hadnt plan on making any unless special ordered..at the time i couldnt afford it but after the aviator is running im going to have them make me one with their A5 straight cut kit... $$$$$$

      Gota get the avi motor pulled,rebuilt and back in first...
       
    19. CDW6212R

      CDW6212R Hauls the mail. Elite Explorer

      Joined:
      June 17, 2004
      Messages:
      18,645
      Media:
      5
      Albums:
      1
      Likes Received:
      869
      Trophy Points:
      143
      City, State:
      Knoxville, TN
      Year, Model & Trim Level:
      98 Limited AWD
      Ouch, the projects like to eat too much. My work truck/DD needs a radiator, and I don't have time right now. Do what you can, fingers crossed here.
       
      • Like Like x 1
    20. 4pointslow

      4pointslow Explorer Torture Tester Elite Explorer

      Joined:
      April 3, 2008
      Messages:
      2,764
      Likes Received:
      293
      Trophy Points:
      103
      City, State:
      Gloucester City, NJ
      Year, Model & Trim Level:
      98 2Dr,98 & 04 4dr xlt
      Shows how much power that engine is making!
       
    21. jd4242

      jd4242 Explorer Addict

      Joined:
      October 15, 2008
      Messages:
      10,821
      Likes Received:
      280
      Trophy Points:
      113
      City, State:
      va beach
      Year, Model & Trim Level:
      92explorer&94 ranger
      Well think this t5 was rated at like 300ish lbs of tq, i made like 450ish at like 3k
       
      Last edited: March 3, 2018
      • Like Like x 2

    Share This Page







    We Support Our Troops!