1. Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!

    Click Here to start your membership and get rid of the ads!

    Dismiss Notice
Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

MFT Black / Blank Screen

Discussion in '2011-2016 My Ford Touch / In Vehicle Technology' started by nick75035, September 28, 2011.

^^Searches ExplorerForum.com^^





  1. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    25,092
    Likes Received:
    1,208
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2020 Aviator Reserve
    Callsign:
    VE3
    Huh? :scratch:

    Peter
     
  2. Support EF

    Elite Explorer 2 for 1 Sale! $20 for 2 years!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. FordIVTteam

    FordIVTteam Official Ford Rep

    Joined:
    July 13, 2011
    Messages:
    1,690
    Likes Received:
    1
    Trophy Points:
    58
    City, State:
    Dearborn, MI
    Year, Model & Trim Level:
    Ford Explorer
    Hi, 2012 WHT PLAT X,

    I recommend a visit to your dealership for this. They're in the best position to determine the issue. As far as disconnecting the battery, we advise to leave that up to your dealership as well. Let me know how it goes! :D

    Rebecca
     
  4. LukerDooker

    LukerDooker Active Member

    Joined:
    March 25, 2013
    Messages:
    886
    Likes Received:
    8
    Trophy Points:
    28
    City, State:
    N.E.
    Year, Model & Trim Level:
    2013Limited 301A TuxBlack
    just hoping for an image with a red circle around the actual fuse area, in case 1 day i will need to look under there....thanks
     
  5. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    25,092
    Likes Received:
    1,208
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2020 Aviator Reserve
    Callsign:
    VE3
    Okay, I'm with you now. That part about 5 years....kind of threw me.
    I thought that the passenger compartment fuse box had been moved to under the hood but according to the 2013 Owner's Guide, it is still in that almost inaccessible location under the dash. I'm not sure if the actual fuse box is layed out the way it is in the manual but if it is #29 doesn't look to difficult to get at. That is once you have contorted your body in such a way as to be able to get at it. :D

    Peter
     
  6. new to ford

    new to ford Active Member

    Joined:
    March 16, 2011
    Messages:
    582
    Likes Received:
    3
    Trophy Points:
    28
    City, State:
    Rochester Hills, MI
    Year, Model & Trim Level:
    11XLT202A 17Sport401A
    My ford touch is dead

    Hi Rebecca,

    My MFT screen (XLT no NAV) went dead/black about five days ago. Over the last year or so, it would occasionally go blank but would start up shortly after with a "scheduled maintenance" and it would "fix itself". This time it hasn't.
    I did the fuse #29 pull several times and that is not working.
    I know I am pulling the right fuse, because when I remove and re-install, the satellite radio works for a few minutes on channel 184 (no screen though) but then the radio cut's off and it's back to "audio off" in the cluster display and the 7" touch screen remains black.
    I am not running the recently relesed MFT software, but at this point, with a blank screen, I don't want to insert a USB with the latest file and if I screw something up the dealership might blame me.
    What could the issue be?
    I am scheduling an appointment with the dealership.
    Thanks,
     
  7. Sgt1411

    Sgt1411 Elite Explorer

    Joined:
    February 22, 2011
    Messages:
    4,258
    Likes Received:
    327
    Trophy Points:
    103
    City, State:
    VanBC/GoodyearAZ
    Year, Model & Trim Level:
    2017 Explorer SPORT
    You need a new APIM
     
  8. FordIVTteam

    FordIVTteam Official Ford Rep

    Joined:
    July 13, 2011
    Messages:
    1,690
    Likes Received:
    1
    Trophy Points:
    58
    City, State:
    Dearborn, MI
    Year, Model & Trim Level:
    Ford Explorer
    I can't diagnose your concern, new to ford, that's best left up to your dealership; however, if the screen hasn't come back on, inserting the USB with the update on it won't do anything. Let me know how your visit to the dealer goes!

    Rebecca
     
  9. new to ford

    new to ford Active Member

    Joined:
    March 16, 2011
    Messages:
    582
    Likes Received:
    3
    Trophy Points:
    28
    City, State:
    Rochester Hills, MI
    Year, Model & Trim Level:
    11XLT202A 17Sport401A
    Hi Rebecca:
    Magically, after about five days of a black screen, it came back to life, this is after unsuccessfully trying to revive it the day before with a fuse #29 pull, go figure...
     
  10. FordIVTteam

    FordIVTteam Official Ford Rep

    Joined:
    July 13, 2011
    Messages:
    1,690
    Likes Received:
    1
    Trophy Points:
    58
    City, State:
    Dearborn, MI
    Year, Model & Trim Level:
    Ford Explorer
    That's great to hear, but I'd still make an appointment to have them make sure everything is okay.

    Rebecca
     
  11. ERIC198

    ERIC198 New Member

    Joined:
    December 8, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    MARYLAND, ROCKVILLE
    Year, Model & Trim Level:
    FORD EXPLORER 2014 XLT
    2014 explorer xlt touchscreen is dead =(

    Today we had some blizzard & snows in the area, when i stepped into my new explorer which only had 2000 miles on it, the touchscreen is dead. I tried to turn the engine off, open the door and reignited it and still no help. The only thing i can see from the touchscreen is the ford welcome logo and the rear-view camera on the reverse gear. All the features are gone. No phone, no navi, no climates, no entertainments. I tired to call ford and the dealer no one picks up the phone. I tried to talk to a rep online with live-chat but he wasn't really helping much.

    Man! I feel very disappointed. This is our first ford and it has already let me down. We only buy new cars in our family and we keep them well maintained for longer lifespan. I already found a few problems with this new explorer, sometimes the screen doens't work but it should be fixed by restarting the vehicle. Another problem is i can't somehow get the wifi to work because it doesn't take enough characters for the passcode. I must admit it, microsoft system sux. I will hate to admit that it's a mistake to pursuad my wife in getting this vehicle.

    Anyone knows what should i do?

    I really don't like to visit the deal and spend another half day there.

    = (
     
  12. 182RG

    182RG Active Member

    Joined:
    May 9, 2011
    Messages:
    878
    Likes Received:
    11
    Trophy Points:
    28
    City, State:
    Winchester, VA
    Year, Model & Trim Level:
    '11 XLT / '13 Touareg TDI
    Do a search on "fuse 29 pull" or "battery cable pull".

    Either of these will hard reset the APIM. Good first thing to try.
     
  13. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    25,092
    Likes Received:
    1,208
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2020 Aviator Reserve
    Callsign:
    VE3
    Welcome to the Forum ERIC198.:wavey:
    Sorry to read that you're having issues with the MFT. There is a thread in the 'Sticky' section MFT Acting Up? Try this that you may also want to try. If non of the suggestions work in restoring the screen functions you likely have a bad APIM which the dealer will have to replace. :(
    You may also want to send a PM (private message) to Rebecca (FordIVTteam), a Ford rep who monitors this thread. You can use this link;
    http://www.explorerforum.com/forums/private.php?do=newpm&u=181992
    Include your name, daytime phone number, VIN, mileage, and dealership info in your message.
    Good luck.

    Peter
     
    Last edited: December 8, 2013
  14. ERIC198

    ERIC198 New Member

    Joined:
    December 8, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    MARYLAND, ROCKVILLE
    Year, Model & Trim Level:
    FORD EXPLORER 2014 XLT
    Thank you for the reply peter

    Just a few moments ago, when I had my tools ready to pop the hood, I did my last attempt to start the vehicle,and it just came back to work! I feel luckily that it's working again, at same time concerned about this problem may happen again in the future. I don't know if it was caused by the freezing weather? may be it worked again because the engine ran a bit? I don't know and I will probably never know. I have the most updated software and I still have ran into some problems.

    A few months ago I encountered a navi issue that the map disappeared from the screen, the only thing I see on the navi screen was a green instructional route line, no map, no street names. I was ready to go out and it just won't work. I had to use my navigation on my cellphone to get on the road first, else I would be late for my schedule.

    Again, this is my first Ford, people has been saying how reliable it is , from my personal experiences, it is not reliable at all. I will also send this message to Rebecca, I really hope there is going to be a newer update to fix all these issues. = (


     
  15. FordIVTteam

    FordIVTteam Official Ford Rep

    Joined:
    July 13, 2011
    Messages:
    1,690
    Likes Received:
    1
    Trophy Points:
    58
    City, State:
    Dearborn, MI
    Year, Model & Trim Level:
    Ford Explorer
    Hey, ERIC198,

    I responded to your PM last week but haven't heard from you. I just want to check in with you to see if you still need help or if your issue has been resolved. Let me know when you get a chance.

    Peter -

    As always, thank you for sending ERIC198 my way! :)

    Rebecca
     
  16. asalazar7007

    asalazar7007 New Member

    Joined:
    July 24, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Miami, Florida
    Year, Model & Trim Level:
    2011 Explorer XLT
    2011 Explorer Sync has a blank screen

    In September of 2013, I schedule my maintenance with my local dealer (Palmetto Ford in Miami, FL). I requested that my Microsoft Sync recieves an update. I picked up the car, and the technician told me he did not have enough time. My warranty for the explorer has expired in May of 2014. Now my Sync has a blank screen. I removed the negative cable from the battery to reset and nothing. I have an appointment with the dealership this coming Monday. I am worried after obvious technical issues with my ford sync along with 1000's of other owners that I will be billed for this repair. I will wait anxiously, and report back.
     
  17. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    25,092
    Likes Received:
    1,208
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2020 Aviator Reserve
    Callsign:
    VE3
    Welcome to the Forum asalazar7007.:wavey:
    I have merged your thread with this existing one. If it is totally black, there is a good chance that the APIM is bad and needs to be replaced. I have posted a picture of it in this thread. Ford has extended the warranty on the APIM to 5 years regardless of mileage so you should be okay if that is the issue.
    Good luck.:thumbsup:

    Peter
     
  18. VTL

    VTL New Member

    Joined:
    February 5, 2015
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2012 XLT
    Issue, screen wont turn on

    Hi guys

    I just got a Explorer 2012 with a black screen, The screen wont turn on, the phone wont sync and the cluster says that the music is off.
    I have tried to disconnect the battery with no success and the the fuse 29.
    When I disconnect the fuse the radio turned on but the screen not and like after 20sec it turned off again.

    The person that I bought the car told me that the dealership told him that he needed this module BT4Z14D212BA. Can this be the problem?

    Thanks for all the help!
     
  19. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    25,092
    Likes Received:
    1,208
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2020 Aviator Reserve
    Callsign:
    VE3
    Welcome to the Forum VTL.:wavey:
    What you probably need is a new APIM (Accessory Protocol Interface Module).
    It is the 'brains' of the MFT system. The part number seems to be correct. Fordparts.com shows it as being $650.67 but Ford has extended that warranty on the APIM to 5 years, unlimited mileage. Good luck.
    I merged your thread with existing one.

    Peter
     

    Attached Files:

  20. VTL

    VTL New Member

    Joined:
    February 5, 2015
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    2012 XLT
    No luck with ford warranty here ( venezuela) just wanted to be sure that I am purchasing the right part.
    On the Ford catalogue the image is different than the APIM. Is this ok?
     
  21. dco43054

    dco43054 Well-Known Member

    Joined:
    April 24, 2003
    Messages:
    1,285
    Likes Received:
    8
    Trophy Points:
    48
    City, State:
    cmh
    Year, Model & Trim Level:
    16 XLT
    That's a tough one. I'm guessing this is a vehicle not sold by Ford in Venezuela? In the U.S., they've warrantied the MFT for 5 years.

    In the U.S., electrical parts are typically not returnable once opened. It could get expensive trying to swap parts to find the cause, and it may require a dealership's computer to set up the new unit after installation.
     

Share This Page







We Support Our Troops!