Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Need help, I'm lost

Discussion in 'A/C & Heater systems - HVAC' started by Wtaylor2007, November 7, 2019.

^^Searches ExplorerForum.com^^





  1. Wtaylor2007

    Wtaylor2007 New Member

    Joined:
    July 13, 2016
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    City, State:
    Monticello,MN
    Year, Model & Trim Level:
    2002 xlt
    2002 explorer xlt. 4.0 261k
    Manual HVAC controls no rear air.

    Now that it's getting colder the temperature of my heat is awful.

    I replaced the temp door actuator when I purchased @171k.

    Recirc door is closed.
    I removed the heater control valve because it wasn't opening or closing when changing the selector, I plan on replacing.

    I have had the heater core back flushed and both hoses get hot, yet still mediocre heat.

    I'm at a loss, there is plenty of air flow but like warm heat. Could the temp door be the culprit even though no cold outside air is getting in?

    What am I missing?
     
    Last edited: November 7, 2019
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



Share This Page







We Support Our Troops!