Dismiss Notice



Register Today It's free! This box will disappear once registered!

NO blower fan, A/C or anything.

Discussion in 'A/C & Heater systems - HVAC' started by Backwoods "X", June 21, 2011.

  • Searches ExplorerForum.com
    1. Backwoods "X"

      Backwoods "X" Active Member

      Joined:
      June 20, 2011
      Messages:
      221
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Mt. Sterling, Ky
      Year, Model & Trim Level:
      94 XLT
      Okay. We just bought this 94 "X" and the biggest issue that it has is that the fan blower does absolutely nothing, regardless of setting ( Low through High ) A/C button doesn't illuminate when pushed and the A/C clutch doesn't engage when the button is pushed. Is it possible for the entire switch panel to be faulty, and cause all of these symptoms? I have checked the fuses and they are looking to be acceptable. I also have "jumped" the compressor clutch and the low pressure switch. BOTH have passed as far as the testing goes, based on information from here. I am going to be pulling and checking the resistor pack next.Any thoughts would be appreciated.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Backwoods "X"

      Backwoods "X" Active Member

      Joined:
      June 20, 2011
      Messages:
      221
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Mt. Sterling, Ky
      Year, Model & Trim Level:
      94 XLT
      So, no thoughts on this? The resistor pack has tested to be good when I installed it in the BII that we also have. I am going to be checking wires next.
       

    Share This Page







    We Support Our Troops!