Dismiss Notice



Register Today It's free! This box will disappear once registered!

No crank

Discussion in 'New Member Introductions' started by EzMoney, July 1, 2016.

  • Searches ExplorerForum.com
    1. EzMoney

      EzMoney New Member

      Joined:
      July 1, 2016
      Messages:
      1
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Sioux City Iowa
      Year, Model & Trim Level:
      2006 Explorer
      Hi, I'm new to the site looking for some help please lol loosing my mind here ok sooo. A while back I put an amp and subs and new head unit in I'm not sure if it happened before this but afterwards for sure it would not start so I bought a new battery still nothing put a new alternator in still nothing put a new starter in still nothing as I was about to give up my buddy told me to try a different key wah-la she started right up. So I figured maybe the key was worn out whatever I had 2 others anyways a few months down the road she would not crank again until she wanted too I guess and then no issues for abother few months now she won't crank again I was stranded at work a work mate told me to check the terminals the positive lead was loose tightened it up and jump started it got it home and now no crank issue again please help

      Also side note the key wiggles in the ignition not sure if ford's are made like that, I also checked fuses and relays all look good
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!