Dismiss Notice



Register Today It's free! This box will disappear once registered!

No forward or reverse

Discussion in 'Stock 2002 - 2005 Explorers' started by bigskinsfan, June 10, 2015.

  • Searches ExplorerForum.com
    1. bigskinsfan

      bigskinsfan New Member

      Joined:
      March 3, 2015
      Messages:
      12
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Virginia
      Year, Model & Trim Level:
      2005 Ford Explorer
      I have an 05 Explorer XLT 4x4 that I just finished a transmission rebuild. It had no forward prior to the rebuild. It slammed into reverse and was rough. Now that the rebuild is complete, it won't go forward or reverse. I've double checked all of the connections, and everything looks good. Fluid level is spot on. No harsh noises or sounds. No leaks.

      Here is what was done:
      Replaced the 3 servos
      Installed a shift correction kit
      new frictions
      new steels
      new bands (all 3)
      various O rings and seals

      What am I missing? Where else can I look? Any help would be appreciated.

      Thanks in advance!
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. BrooklynBay

      BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      52,682
      Likes Received:
      272
      Trophy Points:
      113
      City, State:
      Brooklyn, NY
      Year, Model & Trim Level:
      88 89 93 95 96 Aerostars
      Did you use the same kind of filter? A shallow filter is for RWD while a deep filter is for 4 X 4 (deep pan).
       
    4. drdoom

      drdoom Well-Known Member

      Joined:
      December 13, 2007
      Messages:
      4,121
      Likes Received:
      82
      Trophy Points:
      68
      City, State:
      VA
      Year, Model & Trim Level:
      2005 Eddie Bauer 4.6L 4X4
      I would check to see if you failed to engage the manual valve when reinstalling the valve body.
       
    5. bigskinsfan

      bigskinsfan New Member

      Joined:
      March 3, 2015
      Messages:
      12
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Virginia
      Year, Model & Trim Level:
      2005 Ford Explorer
      Definitely used the same, deep, filter.

      Thanks for the suggestion!
       
    6. bigskinsfan

      bigskinsfan New Member

      Joined:
      March 3, 2015
      Messages:
      12
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Virginia
      Year, Model & Trim Level:
      2005 Ford Explorer
      Thank you. I believe I set it correctly but will double check this if nothing external proves to be the issue.
       

    Share This Page







    We Support Our Troops!