Dismiss Notice



Register Today It's free! This box will disappear once registered!

No power to blend door actuator

Discussion in 'Stock 1995 - 2001 Explorers' started by Kungfoon, September 24, 2016.

  • Searches ExplorerForum.com
    1. Kungfoon

      Kungfoon New Member

      Joined:
      September 24, 2016
      Messages:
      3
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Bellevue, WA.
      Year, Model & Trim Level:
      2001 Ford Explorer 5.0
      I'm sure there's probably been a lot of posts that talked about the Blend door actuator but I never got the answer. So, guess this will be another one. My question: why is there no power going to the blend door actuator in my 2001 Ford Explorer even if the fuses are good? Please help! Spent all day pulling that darn thing out!
      Thanks in advance!
      Kungfoon
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Mike65

      Mike65 Elite Explorer

      Joined:
      December 31, 2013
      Messages:
      1,937
      Media:
      4
      Likes Received:
      49
      Trophy Points:
      58
      Location:
      In my garage
      City, State:
      Toms River, NJ
      Year, Model & Trim Level:
      00 Ranger 4x4, 99 Sport
    4. koda2000

      koda2000 Explorer Addict

      Joined:
      September 2, 2011
      Messages:
      12,167
      Likes Received:
      831
      Trophy Points:
      143
      Year, Model & Trim Level:
      x
      I had this problem on one of my 2000 Mountaineers last fall. It has the automatic HVAC controls. It turned out the EATC unit was bad. Check with forum member LoquetusofBorg. He's amassing quite a collection of EATC units. Maybe he has a spare to sell.
       

    Share This Page







    We Support Our Troops!