Dismiss Notice



Register Today It's free! This box will disappear once registered!

noise from somewhere????

Discussion in 'Under the Hood' started by 97splorer, October 8, 2002.

  • Searches ExplorerForum.com
    1. 97splorer

      97splorer Active Member

      Joined:
      April 20, 2002
      Messages:
      572
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Overland Park, Kansas
      Year, Model & Trim Level:
      '97 XLT 5.0 AWD
      My X kinda makes a ticking noise that seems to be coming from the drivers side of the engine. It almost sound like a tiny exaust leak maybe but I can't pinpoint exactly where the ticking is coming from. Has anyone else heard this ????? Should I be worried? I have had my explorer for a couple years and its always made that noise. I appriciate any info

      thanks
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Jason_25

      Jason_25 Elite Explorer<br>ECX Member

      Joined:
      November 26, 2000
      Messages:
      5,340
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      New Bern, NC
      Year, Model & Trim Level:
      '95 Explorer "Expedition"
      It's either lifters tapping, or an exhaust leak, both of which are normal. But usually, the exhuast leak happens on the passenger side.

      How many miles?
       
    4. TPLYNCH

      TPLYNCH Well-Known Member

      Joined:
      November 19, 1999
      Messages:
      3,196
      Likes Received:
      2
      Trophy Points:
      0
      City, State:
      Brewster, NY
      Year, Model & Trim Level:
      1999 XLS
      Check your EGR tube. They are notorious for getting pinhole leaks on the 5.0 engines, and the result is a ticking noise. I'd also check the rest of your vacuum lines as well.
       
    5. 97splorer

      97splorer Active Member

      Joined:
      April 20, 2002
      Messages:
      572
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Overland Park, Kansas
      Year, Model & Trim Level:
      '97 XLT 5.0 AWD
      I have just over 80k on it... by the way TPLYNCH, where is the EGR tube? where would I find a diagram of all vacuum lines?
       
    6. TPLYNCH

      TPLYNCH Well-Known Member

      Joined:
      November 19, 1999
      Messages:
      3,196
      Likes Received:
      2
      Trophy Points:
      0
      City, State:
      Brewster, NY
      Year, Model & Trim Level:
      1999 XLS
      Sorry, I'm not exactly sure where on 5.0. Run a search for it and you should find the info. It has been discussed, and pretty recently at that.
       

    Share This Page







    We Support Our Troops!