Dismiss Notice



Register Today It's free! This box will disappear once registered!

o/d light flashing

Discussion in 'Stock 1995 - 2001 Explorers' started by onefutrmilnair, July 19, 2011.

  • Searches ExplorerForum.com
    1. onefutrmilnair

      onefutrmilnair New Member

      Joined:
      February 7, 2011
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      portland, orange
      Year, Model & Trim Level:
      2001 ranger
      My o/d light is flashing. I can reset the computer by removing the neg. battery cable and everthing is okay for a week or so. when the light is off it drives fine, when the light is on it shifts hard. Ford gave me the cod p0733 and said that 3rd gear is slipping and I need a tranny rebuild. I don't believe them cause it shifts just fine when the light is off. Has anybody else had this problem. I have done a little research and found out there is a powertrain control module or a speed sensor that could be a problem. If anybody can help that would be great. It is a 1995 ford explorer.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!