Dismiss Notice



Register Today It's free! This box will disappear once registered!

O/D OFF light FLASHING What the ?

Discussion in 'General Explorations!!' started by imy.ca, September 17, 2002.

^^Searches ExplorerForum.com^^
  1. imy.ca

    imy.ca New Member

    Joined:
    March 25, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    British Columbia
    Year, Model & Trim Level:
    1996 Sport Expedition
    Hi all, I've got a 1995 Sport Explorer anyone give me any ideas on what this is.... the Overdrive light is flashing.... I won't driving it for a few days I guess... once i'm at about 30 Kmph it makes a bang sound... excellerates and shifts from D to D2 etc... fine...

    CC email imyventures@hotmail.com so I can check feedback while at work.

    Some one give me any idea of what it is and estimated cost in CANADA to fix

    Thanx... in advance

    Wil
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. Howard

    Howard Moderator Elite Explorer Staff Member Moderator Elite Explorer

    Joined:
    May 17, 2002
    Messages:
    4,196
    Likes Received:
    3
    Trophy Points:
    58
    City, State:
    Milton Keynes
    Year, Model & Trim Level:
    1998 SOHC UK SPEC
    It could be any number of things so get the code read and go from there.
     
  4. TPLYNCH

    TPLYNCH Well-Known Member

    Joined:
    November 19, 1999
    Messages:
    3,196
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    Brewster, NY
    Year, Model & Trim Level:
    1999 XLS
    Try disconnecting your battery for 30 minutes to reset the computer. If it goes away, great. If not, then you have a problem....
     
  5. BAYDOG

    BAYDOG Active Member

    Joined:
    July 28, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Phelps NY
    Year, Model & Trim Level:
    95 Sport
    Mines in the garauge right now for the same exact thing, same year , same modle and year. I tried to reset like said above , worked for a few miles. Had it flushed, still came back. Now it is back in there. No codes came up from the scanner. I'll let ya know when I get it back.
     
  6. aqs789

    aqs789 Member

    Joined:
    February 3, 2002
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    NY
    Year, Model & Trim Level:
    '98 Sport 4x4 SOHC
    After I got a tranny flush and filter change from the dealer my O/D off light started blinking about 50 miles of driving. I brought it back to them and was like WTF you guys do. They said I needed a tranny rebuild so it was covered under extended warranty. Hopefully your's doesn't need the same thing I did. Goodluck
     
  7. Zenscloud

    Zenscloud New Member

    Joined:
    April 13, 2002
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Albany,OR
    Year, Model & Trim Level:
    '95 Explorer Sport
    Yeah, the same thing happenned to me. You'd better get it checked at a tranny shop. Mine was slamming too. I later found out that I had lost second gear (due to a pressure sensor), and it was shifting from first to third. It may be initially expensive, but if you don't get it done soon, you may be getting into more expensive problems.
     
  8. AKJello

    AKJello New Member

    Joined:
    September 19, 2002
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Crestview, FL
    Year, Model & Trim Level:
    1995 XLT
    I had the exact same thing about 2 years ago. Tried the computer reset...didn't work. Took it to a shop and they shot down the throttle postition sensor. Haven't had a problem since.
     






We Support Our Troops!