Dismiss Notice



Register Today It's free! This box will disappear once registered!

od light flashing

Discussion in 'Stock 1995 - 2001 Explorers' started by med, July 18, 2011.

  • Searches ExplorerForum.com
    1. med

      med Member

      Joined:
      October 26, 2004
      Messages:
      91
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      hope, ar
      Year, Model & Trim Level:
      '97 X xlt 4x
      On the way to work tonight the light started flashing. Is there usually an easy fix or is it always major problems? I'm going to try to get a problem code on it tomorrow. Its a 97 4x4 with 93k miles. Never any hard running other than pulling a boat during hunting season. This actually happened last December. It started flashing on the way home from a hunting trip and the next day I planned to have it checked but it had stopped doing it. .... ...until today.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Doubt Incarnate

      Doubt Incarnate Active Member

      Joined:
      May 9, 2005
      Messages:
      532
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      "Franktucky", Ohio
      Year, Model & Trim Level:
      '99 Eddie Bauer
      what motor? not sure if the OHV and the SOHC had the same tranny. it may be a stuck torque converter clutch, if you can feel the shifts count them, if its a 4rXXX transmissiopn its shoulnd shift 3 times then it should feel like a 4th time when the clutch locks the torque converter up, and likewise 4+1 on the 5rxxx trans.
       
    4. med

      med Member

      Joined:
      October 26, 2004
      Messages:
      91
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      hope, ar
      Year, Model & Trim Level:
      '97 X xlt 4x
      It's got the v6. And yes I can feel it shift..... Ill try to pay attention to it on my way home in the morning.
       
    5. med

      med Member

      Joined:
      October 26, 2004
      Messages:
      91
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      hope, ar
      Year, Model & Trim Level:
      '97 X xlt 4x
      got in it and left work. hit the highway and just eased up to the speed limit and the light went out. 35 miles and never came back on.
       
    6. Blee1099

      Blee1099 Evil Asian EF Vendor Moderator Emeritus

      Joined:
      March 3, 2002
      Messages:
      14,037
      Likes Received:
      4
      Trophy Points:
      58
      City, State:
      Elkridge, MD
      Year, Model & Trim Level:
      91
      The flashing O/D light is a stored code that can be accessed by enhanced OBDII scanners.. Take it to a shop that can read transmission codes.
       
    7. med

      med Member

      Joined:
      October 26, 2004
      Messages:
      91
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      hope, ar
      Year, Model & Trim Level:
      '97 X xlt 4x
      A bud at a garage checked it and said it showed the torque converter solenoid was stuck in the off position. Didn't get the code from him tho. Went to a reputable trans shop and the guy was kinda baffled by my story. He said a solenoid doesn't come back from the dead. Anyway it did it again on thw way to work in almost the same time frame as before. And again wheni left work the following morning it went through all the shifts and the light went out. I'm goibg back to the trans shop Monday to let them hookup to it and get the code and order the solenoid. Then ill go back and get it serviced and the part installed. Hopefully this will fix me.
       
    8. drdoom

      drdoom Well-Known Member

      Joined:
      December 13, 2007
      Messages:
      4,079
      Likes Received:
      76
      Trophy Points:
      68
      City, State:
      VA
      Year, Model & Trim Level:
      2005 Eddie Bauer 4.6L 4X4
    9. G-96XLT

      G-96XLT Active Member

      Joined:
      June 11, 2003
      Messages:
      345
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Toronto, ONT
      Year, Model & Trim Level:
      '96 XLT , '00 Sport
      That code is what it blows but that isn't always the problem. For me it blew a similar code and the OD band was broken. Is it lagging a bit ? .. You will get this stupid solenoid code for a few things but it isn't always exactly that.
       
    10. drdoom

      drdoom Well-Known Member

      Joined:
      December 13, 2007
      Messages:
      4,079
      Likes Received:
      76
      Trophy Points:
      68
      City, State:
      VA
      Year, Model & Trim Level:
      2005 Eddie Bauer 4.6L 4X4
      True that...there are many things that can cause that code.
       
    11. med

      med Member

      Joined:
      October 26, 2004
      Messages:
      91
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      hope, ar
      Year, Model & Trim Level:
      '97 X xlt 4x
      Hmmm...so I guess u should put full coverage back on it and keep driving it...lol
       
    12. drdoom

      drdoom Well-Known Member

      Joined:
      December 13, 2007
      Messages:
      4,079
      Likes Received:
      76
      Trophy Points:
      68
      City, State:
      VA
      Year, Model & Trim Level:
      2005 Eddie Bauer 4.6L 4X4
      Everyone tells me that! LOL That incident took place in Shenandoah National Park, the same week that one tenth of VA was burning. I was thinking that my transmission was going to set another mountain on fire!
       
    13. med

      med Member

      Joined:
      October 26, 2004
      Messages:
      91
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      hope, ar
      Year, Model & Trim Level:
      '97 X xlt 4x
      Lol...so what are my odds that this won't be a bad fix. I don't have a bunch of cash to put into this tranny. Especially sunce I just put a set of Mickey Baja MTZ's on it.
       
    14. med

      med Member

      Joined:
      October 26, 2004
      Messages:
      91
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      hope, ar
      Year, Model & Trim Level:
      '97 X xlt 4x
      Had it checked and the guy said it showed it was the tcc solenoid. He ordered the part and I'm supposed to take it Wednesday. Said they would service it, replace the solenoid and adjust the bands. Fingers are crossed....
       
    15. marsig1

      marsig1 New Member

      Joined:
      July 18, 2009
      Messages:
      5
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Land O Lakes, FL
      Year, Model & Trim Level:
      '95 XLT 4.0
      Keep us posted, troubleshooting the same thing myself!!
       
    16. 92muddyXJ

      92muddyXJ New Member

      Joined:
      May 14, 2011
      Messages:
      18
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Indianapolis
      Year, Model & Trim Level:
      97 Sport 4x4
      I had mine come on just the other day. I had just parked in the drive way at work, ran inside then back out. When I got in I thought I put it in reverse but it landed between reverse and neutral and I hit the gas while looking behind me, I quickly noticed I wasn't moving so I let off the gas and saw where the shifter was. Well, when I shifted to reverse the O/D light was flashing and had never done so before. As I drove off road over to our work barn the light kept flashing. I turned off the Explorer, finished up what I was doing in the barn and when I got in it to go home it didn't come on and never has....wierd.

      Mine is a 97 4x4 SOHC 4.0 with well over 212,XXX miles
       
    17. med

      med Member

      Joined:
      October 26, 2004
      Messages:
      91
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      hope, ar
      Year, Model & Trim Level:
      '97 X xlt 4x
      Picked it up this afternoon. $159 out the door. Tranny was serviced and tcc solenoid installed. Drove it to work and so far so good. The owner of the shop didn't fix it, one of his other workers did. He said everything looked ok but the way he talked he's not impressed at all with this model explorer transmission. I told him I pulled a hunting boat and just kinda gave me a look. I don't dog it and only run 31's on it. Told him it was paid fir and only drive it a couple times a wk except during hunting season. I like my x so I'm gonna keep rolling in it and hope for the best. Thanks for the input guys.
       
    18. Chevellefan

      Chevellefan New Member

      Joined:
      November 22, 2011
      Messages:
      18
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Atlanta
      Year, Model & Trim Level:
      97 XLT Explorer AWD
      mine flashes after about 20 miles then quits flashing after about 5 miles.97 AWD 137,000 took it to my buddy who owns his own tranny shop and he could get a code on the light. Also took it to AAMCO and auto zone. same thing no code.
       
    19. Bigham

      Bigham Member

      Joined:
      May 8, 2000
      Messages:
      98
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      99 Explorer Eddie Bauer
      My OD will flash after I hit a large bump in the road. I turn off the car and it resets right away. is there something that is loose I can check out to correct the problem?

      99 Eddie bauer with 190K miles. 4.0l with auto 5 speed tranny. When the light comes on there are no noticeable issues like a hard shift. If you did not see the light blink you would not have any idea something is going on.
       
      Last edited: August 15, 2012
    20. Macgiobuin

      Macgiobuin Active Member

      Joined:
      June 12, 2006
      Messages:
      196
      Likes Received:
      9
      Trophy Points:
      28
      City, State:
      Northern Virginia
      Year, Model & Trim Level:
      01Sp2W 00Mtr 06B3k 96Astr
      Had the same problem with my 97 ranger; turned out to be the pressure control solenoid--the expensive one.
       

    Share This Page







    We Support Our Troops!