Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Overhead console display fix

Discussion in 'Stock 1995 - 2001 Explorers' started by Thallarsen, May 30, 2007.

^^Searches ExplorerForum.com^^





  1. drummercell

    drummercell New Member

    Joined:
    December 20, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    harrisville, wv
    Year, Model & Trim Level:
    1996 ford eplorer
    I just got my 96 explorer and it didnt come with a overhead display. I was wondering if it was possible to add one useing one from another explorer. . . . . I had a jeep before this and i was able to do that but i dont know about this. . .
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Frank Hannah

    Frank Hannah New Member

    Joined:
    December 28, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Shelby, North Carolina
    Year, Model & Trim Level:
    98 XLT
     
  4. Frank Hannah

    Frank Hannah New Member

    Joined:
    December 28, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Shelby, North Carolina
    Year, Model & Trim Level:
    98 XLT
    0verhead consule--98 Ford Explorer XLT

    When I removed the circuit board it appears that one of the 510 resisters is missing..It looks as if it fell off for the base has some old solder..Would this be why my composs and temp indicator is not working...Where can I get this repaired..My dealer says a new unit will cost $500...The wires and solder on the only 510 resister look ok to me...
     
  5. aricanderson

    aricanderson New Member

    Joined:
    August 30, 2008
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    tally, fl
    Year, Model & Trim Level:
    04 XLT
    other boards without sunroofs

    did anyone figure out the problem for a 95 xlt without a sunroof since the circuit boards are different? The only thing that I noticed that could be wrong with mine is that the lighted display has a burnt spot in one corner. I believe thats the reason its does not work.
     
    Last edited: December 29, 2008
  6. scubba.steve

    scubba.steve Member

    Joined:
    December 6, 2008
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Knoxville Tennessee
    Year, Model & Trim Level:
    1994 Limited
    Great write up!!! I just purchased a 94 Limited. And was wondering why mine wasnt working. My console is slightly diffrent than yours, and i didnt have to remove the sunroof moulding. Instead there were 2 screw's in the garage door compartment. Pulled mine all apart, didnt notice any bunt, or solder marks. Did notice that my led screen was burnt in one corner thou. Can this part be purchased as a single unit? Or do i have to buy the whole console?? Time for me to hit the salvage yard's !!!
     
  7. toypaseo

    toypaseo Flunked daycare Elite Explorer

    Joined:
    January 3, 2003
    Messages:
    7,078
    Media:
    48
    Albums:
    1
    Likes Received:
    369
    Trophy Points:
    103
    City, State:
    outside shovelling snow
    Year, Model & Trim Level:
    ................ 96 XLT ™
    scubba.steve, the F150 board I repaired had a burnt corner also, but worked fine with it...
     
  8. bday_cs

    bday_cs New Member

    Joined:
    October 28, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    '99 XLT
    Great write-up! Thanks a million. Saved me $150+ for new console from dealer. One of my 150 ohm resistors was clearly detached.

    Couple other points to add:

    1. You should use the same value resistors if you need to replace them.
    2. Too much solder can be just as bad as too little... you just need a solid connection. If you get too much on there by accident, use "desoldering braid" to remove it. Available at Radio Shack.
    3. Using a small diameter solder makes things MUCH easier. I used .022 diameter. Also available at Radio Shack.
    4. Using solder flux will greatly help your solder connection by letting the solder flow easier. "Rosin Soldering Flux" also available at Radio Shack.
    5. And I'll just echo the previous comments that a 15-20 watt soldering iron is best. Too much heat will cause the fine traces on the circuit board to lift, and then you'll have a mess. Same applies to reheating the same area over-and-over... try not to resolder the same area too much without letting it cool down completely.

    Thanks again!
     
  9. mgreen6712

    mgreen6712 New Member

    Joined:
    December 27, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Crawfordsville, IN.
    Year, Model & Trim Level:
    2000 Explorer Eddie Bauer
    Overhead Console Fix

    Thanx for the step by step instructions and pics. I realy appreciate it. I have a 2000 Explorer Eddie Bauer. I just finished and it works great. I seem to have the same trouble with my radio display. I don't have any display at all. Any suggestions? Chances are it is the same situation as with the overhead compass. A resistor needs resoldered. If anyone has an idea or had the same trouble and fixed it please let me know. Thanx again for the info.
     
  10. scubba.steve

    scubba.steve Member

    Joined:
    December 6, 2008
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Knoxville Tennessee
    Year, Model & Trim Level:
    1994 Limited


    Maybe i can post a pic of my board in this thread and you can help me decipher it. I sent you a private message
     
  11. sport4work

    sport4work New Member

    Joined:
    January 23, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Stevensville, Maryland
    Year, Model & Trim Level:
    '01 Explorer Sport
    Thallarsen,
    I also want to thank you for the info and pictures. I found one of the "501" resisters had completely come unsolderd on one end. After a quick trip to radio shack for a $10.00 dollar soldering iron, The one I have have in my shop was to big, did the resolder, checked the display before reinstalling and low and behold I'm back in business. I do have one question. Does the display need to be recalibrated?
     
  12. 96V8Xploder

    96V8Xploder Member

    Joined:
    January 24, 2009
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    SD,CA
    Year, Model & Trim Level:
    96 XLT 2WD 5.0L
    My display always reads 140F/60C.I can also turn it on at any time with the key out.I can also roll my power windows down and turn the heater/ac blower on.Does anyone have any idea for a fix? Thanks
     
  13. aricanderson

    aricanderson New Member

    Joined:
    August 30, 2008
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    tally, fl
    Year, Model & Trim Level:
    04 XLT
    ok heres a pic of the console that i have for a 95 xlt without sunroof. I have looked over the board. Has anyone found a common problem with this board or could the problem be somewhere else?

    Thanks
    aric anderson

    [​IMG]
     
    • Like Like x 1
  14. scubba.steve

    scubba.steve Member

    Joined:
    December 6, 2008
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Knoxville Tennessee
    Year, Model & Trim Level:
    1994 Limited
    Thats the same board in my 1994 limited... i inspected it pretty good, didnt have a magnifying glass though. Everything appeared normal. Mine is still not working
     
    • Like Like x 1
  15. aricanderson

    aricanderson New Member

    Joined:
    August 30, 2008
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    tally, fl
    Year, Model & Trim Level:
    04 XLT
    quick update. i hooked up 12volts to the overhead unit and the display works so now i'm going to check my ground and fused #10 10Amp hot in run. I believe the problem is in the power coming in. I'll let you know what i find tommorrow. Or maybe its still in the unit itself. I decided to test the board with 12volts on it and i bet you that the problem lies in the ribbon that runs from the board to the display. Every time i touch the ribbon my display goes on and off.
     
    Last edited: January 25, 2009
    • Like Like x 1
  16. backwater83

    backwater83 New Member

    Joined:
    January 27, 2009
    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    peoria, illinois
    Year, Model & Trim Level:
    '01 f-350
    I had the same problem. My display was also dark in the corner. It was more dim than it should be also, when it worked at all. i have a ford f-350 and my display circuit board is different as well. The diodes on mine were marked 610. I could see that one was burnt, even though it still looked connected. I resoldered that joint, problem solved.

    just look at whatever board you have and look carefully at the diodes. You'll see the problem.

    Good luck
     
    • Like Like x 1
  17. backwater83

    backwater83 New Member

    Joined:
    January 27, 2009
    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    peoria, illinois
    Year, Model & Trim Level:
    '01 f-350
    You don't have to calibrate the MPG, miles til empty, or temp. If your compass is off by a little, you can calibrate that by driving in a circle 4 or 5 times. That will calibrate the compass.
     
    • Like Like x 1
  18. omgyouresexy

    omgyouresexy New Member

    Joined:
    January 26, 2009
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Raleigh, NC
    Year, Model & Trim Level:
    '99 Eddie Bauer
    Thanks for this thread man. When I bought my Ex, the compass/thermostat display was bad. The guy I bought it from said the dealer told him it would be a couple hundred to replace. Undoubtedly, this helped devalue the car a little bit. After resoldering the resistor, works A-OK. Thanks to the OP for finding/sharing this.
     
  19. jlrohio

    jlrohio Active Member

    Joined:
    August 10, 2004
    Messages:
    127
    Likes Received:
    2
    Trophy Points:
    18
    City, State:
    Virginia
    Year, Model & Trim Level:
    2011 Ford Explorer XLT
    As one poster mentioned, in Chrysler/Jeep/Dodge vehicles you can take an overhead console (junk yard) from a vehicle with more options in it and place it in a lesser optioned vehicle with no problem, as the wiring and computers/sensors are all the same in the vehicles.

    Can this be done in Ford Explorer's?

    For example, can I go to the junkyard and start grabbing parts from an Eddie Bauer/Limited Model and place them in a basic XL Explorer? (same/similar year model)??

    How about seats? Can I upgrade to leather seats with electronic seat adjustments, etc??

    Thanks in advance for any answers - I'll also keep searching around these forums - hopefully I'll find the right place where modifications/upgrades are located.
     
    Last edited: February 1, 2009
  20. tbjr8257

    tbjr8257 New Member

    Joined:
    December 7, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    east stroudsburg, pa
    Year, Model & Trim Level:
    99 xlt
    perfect. i found the first resistor solder was broken. works great now. directions were very acurate and pics helped with eveything.
    99 explorer with sunroof.
     
  21. tbjr8257

    tbjr8257 New Member

    Joined:
    December 7, 2008
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    east stroudsburg, pa
    Year, Model & Trim Level:
    99 xlt
    just to follow up if your interested. the solder didn't over heat and seperate. it appears from the vibrations in the truck the solder joints crack over time or if the original solder was to thin from the begining. which all manufacturers do to save money. if you look close you will see a jagged edge as if it cracked. when it overheats the edges will roll over and leave a big gap. just an FYI.
     

Share This Page







We Support Our Troops!