Dismiss Notice



Register Today It's free! This box will disappear once registered!

P0133 O2 Sensor Circuit. Ever replace one?

Discussion in 'General Explorations!!' started by Hummerford, October 2, 2002.

  • Searches ExplorerForum.com
    1. Hummerford

      Hummerford New Member

      Joined:
      October 2, 2002
      Messages:
      12
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Chesapeake, VA
      Year, Model & Trim Level:
      1998 E.B.
      I have had the Check Engine light on for a while on my 1998 E.B Explorer. I finally broke down and went to Autozone and had it read. The guy told me it was a P0133 code (O2 Sensor Circuit, slow response, bank 1 sensor 1) and that I had a faulty sensor on the driver side, forward of the convertor.

      Question one: What is Bank 1, Sensor 1?

      Question two: I think I need to replace my HO2s-11. Any suggestions or recommendations out there? Should I replace both at the same time. Is this a difficult replacement?

      Question three: Does anyone have any experience with this same problem?

      Thanks,
      DT
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!