Dismiss Notice



Register Today It's free! This box will disappear once registered!

P2270 code 04 ford explorer

Discussion in 'Stock 2002 - 2005 Explorers' started by Brent090909, October 5, 2018.

^^Searches ExplorerForum.com^^
  1. Brent090909

    Brent090909 New Member

    Joined:
    October 5, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Alberta
    Year, Model & Trim Level:
    04 expl eddie bauer
    Hey all Im new to this site but hopefully you all can help

    My 04 explorer eddie bauer has been throwing the p2270 code every few days

    Changed the o2 senspr with one from napa a ngk o believe. Voltage stays around .04 v to .2 volts right now at .02 volts idling it takes forever for voltage to change

    Evaporative emission canister valve is always at 0%

    Fuel rail pressure 268.86 kpa
    mass air flow 4.36 g/s
    Manifold absolute pressure 31kpa
    Manifold absolute pressure sensor 31 kpa

    Any help would be appreciated
    I changed the pvc 2 years ago
    I cant see or smell exhaust
    I also just got a new trans put in i know the wiring runs above the trans
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. Number4

    Number4 "I'm counting to 3, then I'm getting your dad." Elite Explorer

    Joined:
    March 16, 2013
    Messages:
    3,907
    Likes Received:
    111
    Trophy Points:
    73
    City, State:
    Woodstock, GA
    Year, Model & Trim Level:
    04 Ford Explorer 4.6l
    I know people report issues with wires being damaged on o2 sensors during trans replacement.

    Not sure what the code is you referenced, would be good to update your post with a short description for it.
     
  4. Justin U

    Justin U New Member

    Joined:
    July 22, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Sterling Heights
    Year, Model & Trim Level:
    2004 Ford Explorer Xlt
  5. sfhess

    sfhess Member

    Joined:
    December 10, 2012
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    16
    City, State:
    Palmdale CA
    Year, Model & Trim Level:
    2002 Explorer XLT RWD V6
    Check rubber vacuum hoses. If they are cracked or rotten they can leak, causing a lean condition.
     






We Support Our Troops!