Dismiss Notice



Register Today It's free! This box will disappear once registered!

Problems with air / heat from front vents on an 03 Explorer

Discussion in 'Stock 2002 - 2005 Explorers' started by HawkeyeExplorer, July 26, 2011.

  • Searches ExplorerForum.com
    1. HawkeyeExplorer

      HawkeyeExplorer New Member

      Joined:
      May 3, 2010
      Messages:
      2
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      2003 Ford Explorer
      I have a 2003 Ford explorer that is having issues with ac and heat not working from the fron vents.

      A year ago, the truck started having issues with the "clicking" noise when adjusting the temp control. I replaced the blend door acuator and all was good. Now, the AC / heat works great out of the rear vents but not from the front vents. No heat and just stale air comes out, not cooled. Any thoughts on what this could be? I did buy the blend door acuator from a parts store (mistake, I know) not from a ford dealer. Could this be the problem again? please help!!
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.

    Share This Page







    We Support Our Troops!