Dismiss Notice



Register Today It's free! This box will disappear once registered!

problems with transmission

Discussion in 'Stock 1995 - 2001 Explorers' started by exploder10, September 5, 2014.

^^Searches ExplorerForum.com^^





  1. exploder10

    exploder10 New Member

    Joined:
    September 5, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    union city,tn
    Year, Model & Trim Level:
    2000 explorer Eddie Bauer
    I'm having problems first j got screwed when I traded for it which has barely been two weeks and already a tranny because mine would not shit into o/d and staryin whinny carried it to a transmission shop they said I needed a new tranny so I got a used one got it n and nothing changed so I've read on hear it could b the gem module so I tried that and nothing still goes to third and sometimes fourth but still no o/d I need some help bad running out of ideas and money to put into it o and still no 4x4 either lol thanks in advance
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


Share This Page







We Support Our Troops!