Dismiss Notice



Register Today It's free! This box will disappear once registered!

Replacement blend door actuator not working

Discussion in 'Stock 1995 - 2001 Explorers' started by halfbakedj14, June 14, 2011.

  • Searches ExplorerForum.com
    1. halfbakedj14

      halfbakedj14 New Member

      Joined:
      April 13, 2010
      Messages:
      43
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      96 explorer
      I purchased a new blend door actuator for my 96 ford explorer, I plugged it in and the actuator started to move to the position I needed it in. I set the actuator in place on top if the heater core and tried cycling through the temps to make sure it worked but the actuator wouldn't move after I initially plugged it in. I took the actuator off of the heater core and it still wouldnt move. I tried installing the actuator on another ford explorer and the actuator still wouldn't move. Would anyone know why this actuator won't move anymore?
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. halfbakedj14

      halfbakedj14 New Member

      Joined:
      April 13, 2010
      Messages:
      43
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      96 explorer
      Well now when I have the new actuator plugged in my ac controls don't work at all, I can't turn on the ac or heat or anything, but when I unplug the actuator the controls work.
       
    4. RomeovilleIL

      RomeovilleIL Well-Known Member

      Joined:
      October 13, 2010
      Messages:
      1,065
      Likes Received:
      2
      Trophy Points:
      48
      City, State:
      Illinois
      Year, Model & Trim Level:
      98 LTD, 00 XLT
      Last year when I replaced a blend door actuator with a Doorman unit from Napa it did not work. Got one from the dealership which looked the same from what I could see but cost twice as much worked perfectly. This was with EATC. Could be very small electronic response differences not read properly by the head unit.
       
    5. halfbakedj14

      halfbakedj14 New Member

      Joined:
      April 13, 2010
      Messages:
      43
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      96 explorer
    6. halfbakedj14

      halfbakedj14 New Member

      Joined:
      April 13, 2010
      Messages:
      43
      Likes Received:
      0
      Trophy Points:
      0
      Year, Model & Trim Level:
      96 explorer
      I'm thinking my new actuator is the problem, after some more reading it seems that most people have trouble with the doorman Blend door actuator(the same one I ordered that doesn't work). And the one from motorcraft seems to be the one that works with my car so I ordered that and we'll see if it works!
       

    Share This Page







    We Support Our Troops!