Dismiss Notice



Register Today It's free! This box will disappear once registered!

RIght rear tail light not working

Discussion in 'Stock 1991 - 1994 Explorers' started by Fordexplorerguy1, February 3, 2012.

^^Searches ExplorerForum.com^^
  1. Fordexplorerguy1

    Fordexplorerguy1 Active Member

    Joined:
    November 14, 2010
    Messages:
    486
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    NC
    Year, Model & Trim Level:
    94 XLT 4.0 tow package?
    So i recently reconnected my multi function switch, and when i tested the signals, the right rear tail light quit working, i replaced the bulb with a brand new one and nothing. all the other signals work, and it doesnt speed up at all either so im really not sure what it could be. I need to get this solved so i can have my truck inspected and get tags for it.
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.

  3. Joe Dirt

    Joe Dirt Explorer Addict

    Joined:
    October 4, 2007
    Messages:
    13,410
    Likes Received:
    9
    Trophy Points:
    0
    Year, Model & Trim Level:
    07 Camry
    Do you have a tilt wheel? May need to check for pinched/bare wires in the column that might be creating a short. Did the bulb you replaced with blow, or is it just not activating?

    Was the MFS you put in sure to be working without issues?
     
  4. Fordexplorerguy1

    Fordexplorerguy1 Active Member

    Joined:
    November 14, 2010
    Messages:
    486
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    NC
    Year, Model & Trim Level:
    94 XLT 4.0 tow package?
    I bought brand new signal lights, and it still didnt work, ill have to check the multifunction switch when i get back in town

    and yes the mfs is working because when i try to signal right, the arrow lights up but it doesn't blink for whatever reason
     






We Support Our Troops!