1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

Rough engine, but goes back and forth between rough and smooth

Discussion in 'Stock 1995 - 2001 Explorers' started by d3ath101, July 15, 2011.

^^Searches ExplorerForum.com^^





  1. d3ath101

    d3ath101 New Member

    Joined:
    June 30, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Amherst, NY
    Year, Model & Trim Level:
    95 xl 4x4
    hey. Just wondering if anyone would know what is causing this. My 1995 explorer xl, 4x4. 4.0 OHC v6 decides every now and then to drive really bad. the engine lacks power, drives really rough, and the engine causes bad shaking while driving at low rpms. At high rpms it lacks power, and is really rough. The part I dont get, is that it will decide all of a sudden to drive perfectly again. And have all of its power back. It drives at speed and gets to 85 while both driving smooth, and rough. It decides as i am driving to drive rough, or smooth, and changes as i am driving. There is no pattern to it. I cleaned MAF, IAC. and put a new, new coil in it.
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. d3ath101

    d3ath101 New Member

    Joined:
    June 30, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Amherst, NY
    Year, Model & Trim Level:
    95 xl 4x4
    Bump


    Please help me guys and gals. Today i took it out and it was really rough, more than usual. but it still drove at 70 on the 990. and it is deff engine related.
     
  4. d3ath101

    d3ath101 New Member

    Joined:
    June 30, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Amherst, NY
    Year, Model & Trim Level:
    95 xl 4x4
    bump

    anyone, still got this problem, i asked another friend, and said it could be a clogged injecter. possibility?
     
  5. jlsparky7

    jlsparky7 Well-Known Member

    Joined:
    April 4, 2009
    Messages:
    1,508
    Likes Received:
    1
    Trophy Points:
    0
    City, State:
    Woodhaven, Mi
    Year, Model & Trim Level:
    1996 5.0 XLT AWD
    Check out the link in my signature. Do the IAC/intake cleaning, seafoam, and spark plugs vid. Sounds like thatll fix ur problems.
     
  6. d3ath101

    d3ath101 New Member

    Joined:
    June 30, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Amherst, NY
    Year, Model & Trim Level:
    95 xl 4x4
    Fixed

    Well, its been a couple of weeks now, since i last posted, found out the problem was injector #4 was bad. Replaced and it is a new truck! If anyone has vibration from engine when driving (when its at a lower rpm) check ur injectors!
     

Share This Page







We Support Our Troops!