Dismiss Notice



Register Today It's free! This box will disappear once registered!

rough idle help!

Discussion in 'Stock 1991 - 1994 Explorers' started by 1991explorerEB, February 5, 2012.

^^Searches ExplorerForum.com^^
  1. 1991explorerEB

    1991explorerEB New Member

    Joined:
    January 1, 2012
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    1991 ford explorer EB
    just recently i started my 1991 explorer and usually when i first start it, it jumps to about 1500 rpms then drops to 1000 and runs fine, and sounds good, but this time when i started it it only went to about 1100 rpms and then idled real funny. if i shut it off and restart it, then it goes back to normal. and if i dont restart it and drive it with the funny idle i get terrible gas milage. any ideas?
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. MrShorty

    MrShorty Explorer Addict

    Joined:
    December 27, 2001
    Messages:
    5,078
    Likes Received:
    10
    Trophy Points:
    58
    City, State:
    Spanish Fork, UT
    Year, Model & Trim Level:
    92 XLT and '87 Bronco II
    Nothing specific, but I'd probably start with a few basic diagnostics: Pull codes (even if the CEL isn't on, check fuel pressure, and check for vacuum leaks.
     






We Support Our Troops!