Dismiss Notice



Register Today It's free! This box will disappear once registered!

Rough idle!!!! Slow take-off!!!!

Discussion in 'Stock 1991 - 1994 Explorers' started by ROBERIZER, March 1, 2010.

  • Searches ExplorerForum.com
    1. ROBERIZER

      ROBERIZER New Member

      Joined:
      February 28, 2010
      Messages:
      23
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Arlington,Texas
      Year, Model & Trim Level:
      99 Explorer XLT 4.0L SOHC
      My 93' Explorer IDLES rough!! And always dies while Idling!! Occasionally Takes Off SLOW!!! Could it be my Loose Squeaky Belt??? Just Replaced Transmission about 1 Month ago if that helps! My New Trans. Is one from the salvage yard,My Explorer has always Idle rough but It is getting Worse!!!
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. BrooklynBay

      BrooklynBay Moderator & long time member. Staff Member Moderator Elite Explorer

      Joined:
      November 11, 2005
      Messages:
      52,820
      Likes Received:
      296
      Trophy Points:
      113
      City, State:
      Brooklyn, NY
      Year, Model & Trim Level:
      88 89 93 95 96 Aerostars
      Welcome to this forum! I've moved your thread into the stock 91-94 section. Clean the MAF sensor & the IAC solenoid valve.
       

    Share This Page







    We Support Our Troops!