Dismiss Notice



Register Today It's free! This box will disappear once registered!

Running boards

Discussion in 'General Explorations!!' started by topo4u2, September 16, 2002.

  • Searches ExplorerForum.com
    1. topo4u2

      topo4u2 Active Member

      Joined:
      September 11, 2002
      Messages:
      125
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Ontario Canada
      Year, Model & Trim Level:
      1995 XLT
      Hello, I have those factory plastic running boards on my XLT. The black rubber matting on the top is lifting in a couple of places. Anyone have this problem and know any cures?
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. ahhjaws

      ahhjaws Moab Edition Explorer

      Joined:
      March 27, 2002
      Messages:
      2,974
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Ft. Collins, CO
      Year, Model & Trim Level:
      1992 Explorer XLT
      I have the first generation X, but my cure was taking them off:D . It works. I think it looks better too.

      Just my .02
       

    Share This Page







    We Support Our Troops!