Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Sorry If This Has Been Asked Before, But I Need To Know

Discussion in 'Stock 1995 - 2001 Explorers' started by kcib2u, December 10, 2010.

^^Searches ExplorerForum.com^^





  1. kcib2u

    kcib2u New Member

    Joined:
    December 2, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Boise,Id
    Year, Model & Trim Level:
    2000 Explorer
    Hello All, Happy Holidays, and Whatever,

    I have a question? Partly answered by Mark Wagner's article on installing an "overhead console". He address this fairly well, however he does not show or state how the console is attached to the mounting bracket?
    :rolleyes:

    How does it DETACTH from the place where it is mounted? I see NO screw attachments visiable.

    Regards,

    KC
     
  2. Support EF

    Elite Explorer 2 for 1 Sale! $20 for 2 years!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. OneLever

    OneLever Active Member

    Joined:
    June 26, 2010
    Messages:
    777
    Likes Received:
    2
    Trophy Points:
    0
    Year, Model & Trim Level:
    97 Mt. 5.0L AWD
    Welcome to the forum.

    See this thread post 8, picture 4, left side. There are two flat push fittings that hold it in in place via compression to the roof. Released simply by pulling down on the assembly after freeing the lip on aft near sunroof.

    Link
     
  4. kcib2u

    kcib2u New Member

    Joined:
    December 2, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Boise,Id
    Year, Model & Trim Level:
    2000 Explorer
    Thanks However

    Thanks OneLever,

    That will certainly help if I need to go that far.

    My problem is not so severe. My console works but the temp it is reading out is incorrect. Starts out at around 117 F and never comes down to true ambient temp.

    My question then becomes where is the themocouple that feeds this console?
    And how do I identify it?

    Thanks,

    KC
     
  5. AMMO_HOOAH

    AMMO_HOOAH Active Member

    Joined:
    December 16, 2005
    Messages:
    857
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    Spokane, Wa
    Year, Model & Trim Level:
    1996 Ex V8, AWD XLT
    On my 96 it's up behind the bumper on the drivers side, kind of up into the body behind the "plastic". Looks like an oversized plug cap.
     

Share This Page







We Support Our Troops!