Dismiss Notice



Register Today It's free! This box will disappear once registered!

SoundDomain.com Forums

Discussion in 'Explorer Audio & Navigation' started by Timmy, September 16, 2002.

^^Searches ExplorerForum.com^^
  1. Timmy

    Timmy Active Member

    Joined:
    April 30, 2002
    Messages:
    379
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Downriver, MI
    Year, Model & Trim Level:
    2002 XLS
    :fire: :fire: :fire: :fire: :fire: :fire: :fire: :fire:

    JEEZ CAN I GET SOME SPEED WITH THIS WEBSITE OR WHAT? I juss thought I would make a post I'm trying to buy something and the website NEVER LOADS i can READ AND POST throughout the WHOLE FORUM of this site before I even get to the INDEX of their forums. What the hell!!!! Does anyone else who use their forums have this problem.

    :fire: :fire: :fire: :fire: :fire: :fire: :fire: :fire:

    timmy
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. sideswipe

    sideswipe Active Member

    Joined:
    August 16, 2000
    Messages:
    987
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Brooklyn, NY
    Year, Model & Trim Level:
    '98 EB
    it happens to me too.
     
  4. Rscotts1

    Rscotts1 Elite Explorer

    Joined:
    October 17, 2001
    Messages:
    512
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Honolulu, Hawaii
    Year, Model & Trim Level:
    2002 XLS
    Same here.....really slow site.
     






We Support Our Troops!