Dismiss Notice



Register Today It's free! This box will disappear once registered!

Speedometer issues

Discussion in 'Stock 1991 - 1994 Explorers' started by johnnyboxturtle, February 1, 2018.

  • Searches ExplorerForum.com
    1. johnnyboxturtle

      johnnyboxturtle New Member

      Joined:
      August 13, 2017
      Messages:
      4
      Likes Received:
      0
      Trophy Points:
      1
      City, State:
      Portland, oregon
      Year, Model & Trim Level:
      1992 explorer xl
      a short time ago my speedometer stopped working properly. It isn't dead but it's not accurate. It reads over and will jump all the way up randomly. It will say I'm doing 70/80 when I'm doing about 35/40. I'm not sure what to look at or replace and I'm pretty uneasy driving in a cop thick area and never knowing my speed.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



    3. roscoe 0202

      roscoe 0202 Elite Explorer

      Joined:
      February 3, 2014
      Messages:
      341
      Likes Received:
      70
      Trophy Points:
      38
      City, State:
      salt lake city utah
      Year, Model & Trim Level:
      1999 explorer sport
      try greasing your cable.
      roscoe
       
    4. FR-425

      FR-425 Used to be a road here. Elite Explorer

      Joined:
      November 21, 2013
      Messages:
      2,639
      Media:
      1
      Likes Received:
      92
      Trophy Points:
      68
      City, State:
      Phoenix, AZ.
      Year, Model & Trim Level:
      1994 Explorer Limited
      yep, lube the cable
       
      • Like Like x 1
    5. Dragon90815

      Dragon90815 93 XL Restore

      Joined:
      June 22, 2010
      Messages:
      50
      Likes Received:
      4
      Trophy Points:
      8
      City, State:
      Long Beach, Ca.
      Year, Model & Trim Level:
      '93 Explorer 4.0L auto4x4
      same problem I'll try lubing it. :) thanks FR-425
       
    6. FixingDaily

      FixingDaily New Member

      Joined:
      September 17, 2010
      Messages:
      49
      Likes Received:
      0
      Trophy Points:
      6
      City, State:
      Boise, Idaho
      Year, Model & Trim Level:
      94 Explorer XLT
      Guys,

      After you lube it, can you report back and let us know if it worked.

      Thanks,

      John O
       
    7. Jason94sport

      Jason94sport Well-Known Member

      Joined:
      April 30, 2001
      Messages:
      4,080
      Likes Received:
      34
      Trophy Points:
      68
      City, State:
      South FL
      Year, Model & Trim Level:
      02 Sport 2WD 5 speed

    Share This Page







    We Support Our Troops!