Dismiss Notice



Register Today It's free! This box will disappear once registered!

Starting Problems with 95' Explorer

Discussion in 'Stock 1995 - 2001 Explorers' started by RobertGatz, June 20, 2014.

^^Searches ExplorerForum.com^^
  1. RobertGatz

    RobertGatz New Member

    Joined:
    June 20, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Chicago, IL
    Year, Model & Trim Level:
    1995 Explorer
    Over the past month or so I've had trouble with my Explorer starting. It cranks and cranks and won't start. Every once in a while it will crank and start. I took it to my local guy and he said it was the Ignition Control Module which I had him replace. Worked ok for a day or two and now won't start. I asked him about the problem and he said that it's probably the computer. I've read that the computer should be reset when components are added. I've also read that if you disconnect the negative on the battery, wait 5 minutes the reconnect it will reset the computer.

    Before I take it back to him to have the computer replaced can anyone offer any insight to this problem. Thanks.
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.
  3. 1Aauto

    1Aauto EF Vendor

    Joined:
    April 1, 2009
    Messages:
    5,290
    Likes Received:
    18
    Trophy Points:
    48
    City, State:
    mass
    Year, Model & Trim Level:
    92 explorer
    If there's a check engine light on you may want to have the code pulled to see what it's pointing to.
     






We Support Our Troops!