Dismiss Notice



Register Today It's free! This box will disappear once registered!

Surging while driving

Discussion in 'Stock 1991 - 1994 Explorers' started by Dabstepper, December 22, 2018.

^^Searches ExplorerForum.com^^





  1. Dabstepper

    Dabstepper New Member

    Joined:
    November 16, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Shelby, NC
    Year, Model & Trim Level:
    1992 Explorer XLT 4x4
    I have a 92 Explorer XLT 4x4 with Apprx 211,000 miles.No CEL. recently its been surging between 35-45 mph if im accelerating. it almost refuses to stay between 1,000 and 2,000 rpms only during that speed. I changed the plugs & wires about 800 miles ago and it fixed it. but the surging has come back...It sounds like its just the 1 plug or injector, but I definitely hear & feel a quick ticking from the front right top of the engine.ive got about 30 lbs at the fuel rail so I changed the filter & pressure regulator and its sill at 30..it takes about 3 seconds to start. battery is putting out 12.94 Volts & alternator is at 14.64 Volts. but the Voltage guage will jump around 9-14 and you can hear the truck make a moan when the voltage drops...



    ideas?
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



Share This Page







We Support Our Troops!