Dismiss Notice



Register Today It's free! This box will disappear once registered!

Sway bar links and odd rubbing

Discussion in 'Modified 2002 - 2005 Explorers' started by HiImBrian, July 30, 2011.

  • Searches ExplorerForum.com
    1. HiImBrian

      HiImBrian Well-Known Member

      Joined:
      September 4, 2009
      Messages:
      1,428
      Likes Received:
      3
      Trophy Points:
      48
      City, State:
      St. Petersburg, Florida
      Year, Model & Trim Level:
      2003 Explorer Eddie Bauer
      I finally got around to changing out my shot sway bar links. I hadn't realized just how bad they were...

      [​IMG]

      While I was down there I noticed some scrapes where the wheel hub assembly was rubbing on the lower arm.... What do you guys make of this?

      [​IMG]

      I didn't check the other side, but will later this afternoon...
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. JDT

      JDT Active Member

      Joined:
      May 9, 2009
      Messages:
      106
      Likes Received:
      1
      Trophy Points:
      0
      City, State:
      Williamstown, Ky
      Year, Model & Trim Level:
      2002 EB
      Mine has the weird rubbing too I think there stops for the steering and with the lift it's at a different angle and the "ball" lookin thing dont go into the "cup" part and it just rubs, also I can pull the front end down by turning the wheel all the way, I think this causes it
       
    4. swshawaii

      swshawaii Explorer Addict

      Joined:
      April 3, 2009
      Messages:
      9,245
      Likes Received:
      301
      Trophy Points:
      93
      City, State:
      Kailua-Oahu, Hawaii
      Year, Model & Trim Level:
      '05 Sport Trac XLS (RWD)
      Normal. Appears to be steering stops doing their job. Use heavy waterproof grease on them.

      Also, don't overtighten the rubber Moog end link bushings. I replaced mine with ES bushings.
       
    5. Kazer

      Kazer Well-Known Member

      Joined:
      March 13, 2010
      Messages:
      1,689
      Likes Received:
      1
      Trophy Points:
      0
      City, State:
      Sneads Ferry, NC
      Year, Model & Trim Level:
      2001 Excursion PSD
      glad to know my ex wasnt the only one doing this
       

    Share This Page







    We Support Our Troops!