Dismiss Notice



Register Today It's free! This box will disappear once registered!

Top Mount TURBO Explorer V8

Discussion in 'Modified 1995-2001 Explorers' started by RegionThr33, December 8, 2017.

^^Searches ExplorerForum.com^^
  1. CDW6212R

    CDW6212R Hauls the mail. Elite Explorer

    Joined:
    June 17, 2004
    Messages:
    18,817
    Media:
    5
    Albums:
    1
    Likes Received:
    905
    Trophy Points:
    143
    City, State:
    Knoxville, TN
    Year, Model & Trim Level:
    98 Limited AWD
    Ditto, this OP turbo system has lots of potential, and the trans plus TC have something to do with the current results. Sorted out a little more, it should see the mid 12's if everything's right. That's about the time weak links may turn up too, parts that are old or original, like u-joints etc. Go at it slow and think through all important parts.
     
    • Like Like x 1
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. RegionThr33

    RegionThr33 Active Member

    Joined:
    December 8, 2017
    Messages:
    134
    Likes Received:
    87
    Trophy Points:
    38
    City, State:
    Alderson
    Year, Model & Trim Level:
    1997 Explorer XLT V8
    If I could only get my tune finalized. My laptop went down and then the transmission went. Still haven't replaced the laptop yet.
     
  4. RegionThr33

    RegionThr33 Active Member

    Joined:
    December 8, 2017
    Messages:
    134
    Likes Received:
    87
    Trophy Points:
    38
    City, State:
    Alderson
    Year, Model & Trim Level:
    1997 Explorer XLT V8
    Haven't updated in a long while. I haven't been able to really do anything recently. Life is hectic sometimes.
    The only real update is that I still need my tune finalized and I need a new ring and pinion. Lots of slop in the rear now.
    I'm also looking at Upgrading my brakes. They really are terrible at high speed.

    Ive been having issues with my wastegates opening way to early (~2.5psi). I even unhooked the boost signal to them and they still open at ~7psi just from exhaust pressure. I'm about to order new springs. Hopefully this remedies this issue.

    WOT is good. I actually (accidentally) took it up to 17psi in 2nd gear. 10psi+ pulls HARD. Its unbelievable the difference.

    The transmission is doing great! Zero issues. The JMod is nice. Shifting is super fast now.

    I drive the explorer every day. I've probably put around 4k miles on it since the transmission build. I actually just took a 600 mile trip last week and averaged 16mpg on the highway.

    I really appreciate all of the great comments and info from everyone. I will eventually get back on track and get this 100%
     
    • Like Like x 4






We Support Our Troops!