Dismiss Notice



Register Today It's free! This box will disappear once registered!

Total loss of coolant

Discussion in 'Stock 2006 -2010 Explorers' started by Anton Gunnarsson, July 20, 2019.

^^Searches ExplorerForum.com^^





  1. Anton Gunnarsson

    Anton Gunnarsson New Member

    Joined:
    July 20, 2019
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Year, Model & Trim Level:
    2006 Explorer V6 4.0
    So here i was in my tuxedo on my way to a wedding when my explorer suddenly lost power and temp gauge started rising, so i pulled into a gas station shut it off and took a look..

    behold me was this sight..

    my question is where is that leaking from?

    67112632_3128972303787060_3813460655634120704_n.jpg

    67215256_917136368646520_6135284838724272128_n.jpg
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Rcflyer330

    Rcflyer330 Active Member

    Joined:
    March 23, 2014
    Messages:
    498
    Likes Received:
    20
    Trophy Points:
    28
    City, State:
    Michigan
    Year, Model & Trim Level:
    2010 Ford Explorer XLT V6
    I am a little confused in the second picture there looks to be a green stream coming out of a metal pipe. you are asking where its leaking from and if that is the leak you have already answered your question.

    If that is not the leak then start by checking all coolant hoses and plastic connectors.
     
  4. Anton Gunnarsson

    Anton Gunnarsson New Member

    Joined:
    July 20, 2019
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Year, Model & Trim Level:
    2006 Explorer V6 4.0
    hoses, upper, lower and thermostat is ok from where i can see.. looks like that pipe has been welded on. is it stock if so what part is it?
     

Share This Page







We Support Our Troops!