Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Transmission Slip

Discussion in 'Under the Hood' started by mrossirr, April 4, 2004.

^^Searches ExplorerForum.com^^





  1. mrossirr

    mrossirr New Member

    Joined:
    November 23, 2002
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Hickory,North Carolina
    Year, Model & Trim Level:
    1999 Sport 4x4
    99 Sport with 51,000 mi.
    Slips about 40 to 50 percnt of the time 2nd and 3rd gear.Took it to my dealer which I have used before with no problems. They replaced the seperator plate,valve body gaskets and filter. Picked it up Friday and it still slips. Taking it back Tuesday. What should the next step be to repair this transmission - rebuild ? Should I take it to a tranny shop like Cottman or Amoco ?
    Thanks in advance
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Robert

    Robert Well-Known Member

    Joined:
    October 26, 1999
    Messages:
    3,956
    Likes Received:
    1
    Trophy Points:
    48
    Location:
    CA
    City, State:
    Kelseyville, CA
    Year, Model & Trim Level:
    '13 Ram 1500 Longhorn
    Pretty low miles for needing a transmission already although it is exibiting one of the signs that mine did before it needed rebuilt. Last summer, when accelerating lightly, I could hear the RPMs rev up just a bit before upshifting. Mine also had a harsh clunk when slowing down to a stop and a bad clank when going from R to D or vice versa. I first tried the updated seperator plate, gasket and switching to Amsoil ATF but it didn't help a bit. End result was that I needed my transmission rebuilt, but I had 95K on it at the time.
     

Share This Page







We Support Our Troops!