Dismiss Notice



Register Today It's free! This box and some ads will disappear once registered!

Turn signals don't work

Discussion in 'Under the Hood' started by technoboy235, May 22, 2009.

^^Searches ExplorerForum.com^^





  1. technoboy235

    technoboy235 Active Member

    Joined:
    December 3, 2008
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Burtonsville, MD
    Year, Model & Trim Level:
    '98 Limited V8 AWD
    A couple days ago I was driving to Rausch Creek Off Road Park and my turn signals started to work intermitently. They started to make a loud fuzzy noise and they were'nt signalling. Throughout the day, They would work for a little while, then do that fuzzy thing and not signal. On the way back that evening, they quit doing anything. When I put the steering wheel all the way up, The hazzard lights would work, but when the steering wheel was fixed at the height that I like it, they wouldnt work either. If someone could help me out with this that would be great.

    Thanks
     
  2. Support EF

    Elite Explorer 2 for 1 Sale! $20 for 2 years!

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. Scottydog

    Scottydog New Member

    Joined:
    May 5, 2009
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Raleigh, NC
    Year, Model & Trim Level:
    '01 Sport Trac
    Happened to me a while back. There is tape holding the bundle of wires to your steering column. If you remove the plastic cover and the metal cover under that, you can access all the wiring. When the steering wheel is tilted up and down it causes a plug to become loose. I never moved mind, but it worked it's way loose over the years.

    Simply cut the tape holding them and it will relieve the tension.
     
  4. 99ex22

    99ex22 Well-Known Member

    Joined:
    June 5, 2008
    Messages:
    1,417
    Likes Received:
    1
    Trophy Points:
    48
    City, State:
    Wilsonville, Oregon
    Year, Model & Trim Level:
    2000 5.0L 4x4 Eddie Bauer
    If that doesnt work it's most likely a bad turn signal switch.
     
  5. fixxxer

    fixxxer Well-Known Member

    Joined:
    September 28, 2006
    Messages:
    1,457
    Likes Received:
    2
    Trophy Points:
    48
    City, State:
    Aurora, Co.
    Year, Model & Trim Level:
    93 XLT 4X4
    Since the hazards work, the more logical diagnosis is a loose connection at the multi-function switch or at the hazard switch. Try what Scottydog suggested first before you start throwing money at it. Once you have the covers off, turn on the turn signals or hazard switch and start wiggling those wires and your lights might just start working again, by wiggling each wire, you can pinpoint which wire or connector is bad and just go from there.
     
  6. Scottydog

    Scottydog New Member

    Joined:
    May 5, 2009
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Raleigh, NC
    Year, Model & Trim Level:
    '01 Sport Trac
    That could also be the case...I tried (and my mechanic) several options before finding the solution. I actually saw the same diagnosis on another web site shortly after we fixed mine. Maybe before you take things apart, try tilting your steering wheel up and then down to see if that has any affect.
     
  7. 99awd50

    99awd50 Member

    Joined:
    February 2, 2009
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    The Bay
    Year, Model & Trim Level:
    99 5 liter
    mine went out yesterday and hazards were still working.. i was like what the hell. Well after inspeciting everything inlcuding the top of the steering column.. the bigger plug-in on top of the steering column just over from the shifter was coming out.. someone in the past broke the retainign tab on it so it could just slide out if tugged on.. so i positioned the steering wheel where i want it.. made sure the plug in was in all the way and put it all back together.. signals work great now.. plus.. when i was troule shooting that plug in would cause a sizzle from having lil or no contact when pulled on.. if i had a way to post pics i have several that i could share. KILL
     
  8. beadyiwoman

    beadyiwoman New Member

    Joined:
    June 14, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Pittsboro, NC
    Year, Model & Trim Level:
    2002 explorer sport trac
    Could this wheel tilt problem contribute to the brake lights staying on continuously when the headlights are on, but not coming on at all when the headlights are off and you step on the brake? I went for an inspection today and found that the brake lights come and stay on if the headlamps are on but don't work when the brake is pressed. The center third light is functioning correctly. In the past I had noticed the blinkers would malfunction after my son in law would drive the car and found it was due to the tilt of the steering wheel being changed. Thanks.
     
  9. simon5ay5

    simon5ay5 New Member

    Joined:
    July 24, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    santa barbara ca
    Year, Model & Trim Level:
    98 5.0v8 awd lxt
    i just bought a 98 exploder and googled '98 exploder turn signals dont work' and this is the first thing that popped up.. it was a 5 min fix and my turn signals are working again. the wires just pulled out of the plug on my turn signals.
     

Share This Page







We Support Our Troops!