Dismiss Notice



Register Today It's free! This box will disappear once registered!

V8 Missing and bogging down

Discussion in 'Under the Hood' started by sliced, December 10, 2004.

^^Searches ExplorerForum.com^^
  1. sliced

    sliced New Member

    Joined:
    December 10, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Palm Desert, Ca.
    Year, Model & Trim Level:
    99 Limited V8
    My 99 limited v8 runs great when it is cold but when it warms up it starts missing and bogging when I give it gas. I changed the plugs, and 1 coil because a scope said it was #8 cylinder that was missing. Help me please.
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. TSTONE

    TSTONE Giddy up! Elite Explorer

    Joined:
    December 31, 2001
    Messages:
    1,191
    Likes Received:
    1
    Trophy Points:
    46
    City, State:
    Oakland County, MI
    Year, Model & Trim Level:
    97 Mountaineer
    could be wires - might also be a convertor failing
     






We Support Our Troops!