Dismiss Notice



Register Today It's free! This box will disappear once registered!

What did you do to your 5th Gen today?

Discussion in 'Modified 2011- 2019 Explorers - Tuning & Mods' started by ibmike, March 17, 2014.

  • Searches ExplorerForum.com
    1. Magnetic619

      Magnetic619 New Member

      Joined:
      January 29, 2015
      Messages:
      33
      Likes Received:
      5
      Trophy Points:
      8
      City, State:
      San Diego, CA
      Year, Model & Trim Level:
      2017 Ford Explorer Sport
      Added tunes from 5Star via SCT X4, this morning.

      91 Octane Performance (stock)
      91 Octanne Performance (3bar, cai)

      night and day difference!
       
      • Like Like x 1
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. fjc2

      fjc2 Elite Explorer

      Joined:
      December 17, 2013
      Messages:
      151
      Likes Received:
      19
      Trophy Points:
      18
      City, State:
      MI
      Year, Model & Trim Level:
      2014 Explorer Sport
      Changed my PTU oil today. That was an adventure, as mine doesn't have a drain plug. Ended up accessing the fill plug through the passenger wheel well (you don't have to remove the liner), and using a hand vacuum pump to pump out the old oil, and pump fresh oil in.
       
    4. Ryant35

      Ryant35 New Member

      Joined:
      November 15, 2017
      Messages:
      19
      Likes Received:
      11
      Trophy Points:
      3
      City, State:
      Cypress
      Year, Model & Trim Level:
      2013 XLT
      Hard wired my new dash cam I got on Cyber Monday from Amazon.
      [​IMG]
      [​IMG]
      I spent way too much time working on it to finally realize I was supplying 12V instead of 5V to it, wondering why it wouldn't turn on.
       
    5. ljcorby

      ljcorby Member

      Joined:
      April 11, 2018
      Messages:
      58
      Likes Received:
      2
      Trophy Points:
      8
      City, State:
      Great Meadows, NJ
      Year, Model & Trim Level:
      2013 Ford Explorer XLT
      Enabled "Bambi Mode" for my fog lights via Forscan....on while the high beams are on. Nice
       
    6. Ryant35

      Ryant35 New Member

      Joined:
      November 15, 2017
      Messages:
      19
      Likes Received:
      11
      Trophy Points:
      3
      City, State:
      Cypress
      Year, Model & Trim Level:
      2013 XLT
      Last week I enabled remote start with Forscan, today I programmed my new 4 button keyfob (I only had 1 to start with) and remote started by Expo! Pretty cool!
       
      • Like Like x 1

    Share This Page







    We Support Our Troops!