1. Tip...
    If you hold most smartphones sideways
    you can bring up a more full featured version of the forum.
    Dismiss Notice
Dismiss Notice



Register Today It's free! This box will disappear once registered!

What improvements came with V2.11?

Discussion in 'Stock 2011 - 2019 Ford Explorer Discussion' started by 1995E, July 20, 2011.

^^Searches ExplorerForum.com^^





  1. 1995E

    1995E Well-Known Member

    Joined:
    July 16, 2010
    Messages:
    1,860
    Likes Received:
    52
    Trophy Points:
    68
    City, State:
    Maryland
    Year, Model & Trim Level:
    95 + 11 Ex both XLT
    Hello. I'm wondering from those who got V2.11 installed, what improvements have you seen? Here is what I'd like to know that got fixed:

    Does it run faster?

    Did they fix it to where when you browse your media device, it stays at the album you want so you don't have to browse through the whole thing again?

    Has phone pairing issues stopped?

    Any new glitches?

    What other improvements do you see?

    Those are the things that I have been wondering about so if you have an answer, please let us know. :)

    Thanks!
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


  3. chimoman

    chimoman B

    Joined:
    February 8, 2011
    Messages:
    617
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    New Brunswick
    Year, Model & Trim Level:
    Explorer 2011 Ltd
    Haven't had a chance to check it out yet. Will report findings.I did notice it was way faster. Did notice that all my album art that didn't show up previous is now showing up. No lag to speak of in anything. To early to tell. Let ya know in a week.
     
  4. 1995E

    1995E Well-Known Member

    Joined:
    July 16, 2010
    Messages:
    1,860
    Likes Received:
    52
    Trophy Points:
    68
    City, State:
    Maryland
    Year, Model & Trim Level:
    95 + 11 Ex both XLT
    Thanks buddy! Glad to hear about this major improvement!
     
  5. TennesseeTider

    TennesseeTider New Member

    Joined:
    June 7, 2011
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Hixson, TN
    Year, Model & Trim Level:
    2011 XLT 4WD
    Not to rain on the version 2.11 party, but it was installed in my Explorer today and the nav system still crashes when the Sirius Travel Link weather radar tries to load.

    I also still had to deal with the "Performing Scheduled System Maintenance" screen. We only drove it about 30 minutes and those issues remain.

    I am now going to try to evoke the Lemon law and get my money back on this one. 6 trips to the dealer and 2 versions of software later (started on 2.4, went to 2.8, and now 2.11) and I still have the same issues.

    Hopefully version 2.11 solves everybody else's problems, but my hopes were dashed.
     
  6. jrmexplorer

    jrmexplorer Well-Known Member

    Joined:
    April 19, 2011
    Messages:
    1,109
    Likes Received:
    1
    Trophy Points:
    0
    Year, Model & Trim Level:
    2011 Limited
    Thus my insistence that software is not the only issue. I think there is some bad hardware out there. The problem is that dealers are not adequately trained on how to debug this thing and actually deal with the problems, and so all ford knows is "MFT is bad" - and they assume software.
     
  7. chimoman

    chimoman B

    Joined:
    February 8, 2011
    Messages:
    617
    Likes Received:
    2
    Trophy Points:
    0
    City, State:
    New Brunswick
    Year, Model & Trim Level:
    Explorer 2011 Ltd
    Yup, you have a lemon. Mine has worked great from day 1. No real big issues. So no need for tissues. Lemons are lemons. Your bound to get some. Good luck with the LEMON law thingy. Here in Canada we go to arbitration. So if you're from Canakistan and have a LEMON. Document everything. Explorer ROCKS. At least mine does. Love driving it. Love MFT. LOVE IT. Getting 11.3 in the city right now.
     
  8. Andy011X

    Andy011X New Member

    Joined:
    July 14, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Dallas, TX
    Year, Model & Trim Level:
    2011 LTD
    Good luck on the lemon law thing. Let us know how it goes. I hope to avoid it, but if things don't improve I will be doing the same thing.
     
  9. flaguy

    flaguy Member

    Joined:
    June 8, 2007
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    "11 XLT
    Anyone have any word on if the "bluetooth noise" is addressed in the new software?
     
  10. uniquename

    uniquename Active Member

    Joined:
    March 24, 2008
    Messages:
    545
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Twin Cities, MN
    Year, Model & Trim Level:
    '11 XLT
    What BT noise? Mine has no issue streaming audio or holding a phone conversation. I have been told it is far superior to the sound in my 08.
     
  11. jrmexplorer

    jrmexplorer Well-Known Member

    Joined:
    April 19, 2011
    Messages:
    1,109
    Likes Received:
    1
    Trophy Points:
    0
    Year, Model & Trim Level:
    2011 Limited
    someone posted that his bluetooth noise issue was resolved by turning down the A/C blower fan and/or the A/C seats.
     
  12. flaguy

    flaguy Member

    Joined:
    June 8, 2007
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    "11 XLT
    The bluetooth noise is the wind tunnel effect anyone receiving a cell phone call hears. I posted that idea about turning down the AC volume, but I since discovered that only helps when the vehicle is stopped or going slow. At highway speeds, people don't even want you to call them.

    see this link for more info on this problem

    http://www.explorerforum.com/forums/showthread.php?t=315634&highlight=phone+noise
     
  13. uniquename

    uniquename Active Member

    Joined:
    March 24, 2008
    Messages:
    545
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Twin Cities, MN
    Year, Model & Trim Level:
    '11 XLT
    It's an SUV...it happens. As I said, mine is much better than the 08. I had AC on full yesterday and had a conversation at 75 mph with no issue.
     
  14. flaguy

    flaguy Member

    Joined:
    June 8, 2007
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    "11 XLT
    How come it happens to some of us and not others?
     
  15. jrmexplorer

    jrmexplorer Well-Known Member

    Joined:
    April 19, 2011
    Messages:
    1,109
    Likes Received:
    1
    Trophy Points:
    0
    Year, Model & Trim Level:
    2011 Limited
    What phone do you have, and do you have "stereo audio" enabled on your phone? If you don't - try enabling it.

    Have you taken it into your dealer? maybe your microphone is defective.
     
  16. flaguy

    flaguy Member

    Joined:
    June 8, 2007
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    "11 XLT
    There is no stereo audio setting on my phone. It is a very recent android smart phone and it should work well with MFT. The dealer said "I couldn't find anything" but if you look at this thread, you'll know that it is more than my phone or my microphone. If it were the microphone, why would it work when you are stopped and not work when you are on the highway? There's more to it than that.

    http://www.explorerforum.com/forums/showthread.php?t=315634&highlight=phone+noise
     
  17. uniquename

    uniquename Active Member

    Joined:
    March 24, 2008
    Messages:
    545
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Twin Cities, MN
    Year, Model & Trim Level:
    '11 XLT
    I looked at the thread, you still don't mention what phone you have. I find it close to impossible that a recent android phone doesn't have a2dp.
     
  18. flaguy

    flaguy Member

    Joined:
    June 8, 2007
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    "11 XLT
    My phone is a Samsung Captivate. My wife has he same problem with her Motorola Tundra.
     
  19. jrmexplorer

    jrmexplorer Well-Known Member

    Joined:
    April 19, 2011
    Messages:
    1,109
    Likes Received:
    1
    Trophy Points:
    0
    Year, Model & Trim Level:
    2011 Limited
    The captivate has bluetooth stereo. Can't find how to turn it on though.

    A quick google search recommends you upgrade to newer software (may have to take it into the cellphone store to do this) as apparently the stock software had bluetooth issues.

    http://www.droidforums.net/forum/samsung-fascinate/110329-anyone-bluetooth-audio-quality-issues.html

    Also, do you have Wi-Fi enabled on either the car or your phone? It seems some users are reporting issues with interference between the bluetooth and the wi-fi.
     
  20. flaguy

    flaguy Member

    Joined:
    June 8, 2007
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    0
    Year, Model & Trim Level:
    "11 XLT
    jrm,

    thanks for the interest and help. I checked the Captivate users manual and stereo is not mentioned anywhere. I do have the most recent software version on the Captivate. Still, the problem is duplicated on my wife's Tundra which seems to rule out the phones.

    I didn't know about any wi-fi problems and I'm not certain if it is turned on in the X. It is off on the Captivate.
     
  21. uniquename

    uniquename Active Member

    Joined:
    March 24, 2008
    Messages:
    545
    Likes Received:
    0
    Trophy Points:
    0
    City, State:
    Twin Cities, MN
    Year, Model & Trim Level:
    '11 XLT
    Touchwiz and motoblur=custom BT stacks. I'd be willing to bet you can find the answers you need online.

    I'm not saying your BT in the ex is perfect, just trying to help you help yourself :)
     

Share This Page







We Support Our Troops!