Dismiss Notice



Register Today It's free! This box will disappear once registered!

windshield washer pump

Discussion in 'Stock 2011 - 2019 Ford Explorer Discussion' started by trump, November 20, 2014.

^^Searches ExplorerForum.com^^





  1. jwright4

    jwright4 Member

    Joined:
    October 28, 2006
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    6
    City, State:
    Albany, NY
    Year, Model & Trim Level:
    2015 Explorer XLT
    Come to find out, the actual problem with mine is the sensor isn't working to tell me the fluid is low. I was in fact out of washer fluid but nothing came on in my msg center. The light doesn't cycle on either in the dash when i turn the key to the on position. Haven't taken it in yet for them to look at. 42k miles.
     
  2. Support EF

    Join the Elite Explorers for $20

    Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.



  3. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    24,400
    Likes Received:
    1,104
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2017 Explorer Platinum
    Callsign:
    VE3
    Does the light will come on briefly at start-up after you refill the container?

    Peter
     
  4. Sunny32_1967

    Sunny32_1967 Active Member

    Joined:
    November 25, 2014
    Messages:
    100
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    Highlands Ranch, CO
    Year, Model & Trim Level:
    2015 Ford Explorer Sport
    Boostking, Did you finally got it checked and what were the results? BTW I am on a road trip from Denver to SLC/UT, Boise/ID, Bend/OR, Florence/OR and then south to Redwood City/CA and then headed back to Denver. Loving the ride/comfort of ExSport.
     
  5. Boostking

    Boostking Active Member

    Joined:
    June 23, 2013
    Messages:
    154
    Likes Received:
    0
    Trophy Points:
    16
    City, State:
    Central Florida
    Year, Model & Trim Level:
    2002 BMW M3/2013 XSport
    Unfortunately I had to reschedule for tomorrow morning, something came up on Friday. So I will report back once I get them to look at it.
     
  6. Boostking

    Boostking Active Member

    Joined:
    June 23, 2013
    Messages:
    154
    Likes Received:
    0
    Trophy Points:
    16
    City, State:
    Central Florida
    Year, Model & Trim Level:
    2002 BMW M3/2013 XSport
    So I was able to go today. The service guy was very nice and ended up taking care of it without issue. He showed me the gunk that was on the filter side of the washer pump. Neither of us have seen this before. Very bizarre. He took care of it no charge and the washer is working again. I will post pictures when I get back to my computer, I'm on my cell phone now.
     
  7. FordService

    FordService Official Ford Rep

    Joined:
    October 25, 2010
    Messages:
    5,281
    Likes Received:
    11
    Trophy Points:
    48
    City, State:
    Dearborn, MI
    Year, Model & Trim Level:
    2014
    That sounds like your best next step, jwright4. Let us know when you head in; I'll continue to check in to see how things progress.

    I'm glad they took great care of you, Boostking. Thanks for sharing your results with us! :)

    Crystal
     
  8. Boostking

    Boostking Active Member

    Joined:
    June 23, 2013
    Messages:
    154
    Likes Received:
    0
    Trophy Points:
    16
    City, State:
    Central Florida
    Year, Model & Trim Level:
    2002 BMW M3/2013 XSport
    [​IMG]

    [​IMG]

    I've never seen anything like it. It was very slimy, almost felt like silly string? He dumped out all the old fluid and refilled it. It should be good to go. I checked my bottles of washer fluid and they had no mystery goo in them, even poured the one I'd been using through a strainer. Oh well, I'm glad its fixed. Thanks for the support.
     
  9. Sunny32_1967

    Sunny32_1967 Active Member

    Joined:
    November 25, 2014
    Messages:
    100
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    Highlands Ranch, CO
    Year, Model & Trim Level:
    2015 Ford Explorer Sport
    Thanks for the response Boostking. I hope they didn't ask you to not use any specific Washer fluid. If they did, please do share. Glad it all worked out fine for you.
     
  10. bamafan2262

    bamafan2262 New Member

    Joined:
    October 26, 2014
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Alabama
    Year, Model & Trim Level:
    2012 explorer XLT
    winshield washer

    I have a 2012 ford explorer xlt. All of a sudden the windshield washer is not pumping fluid i can hear the pump running but no fluid on the rear or front windshield has anyone had this problem or have any suggestion thanks in advance for the help.
     
    Last edited by a moderator: February 12, 2016
  11. bamafan2262

    bamafan2262 New Member

    Joined:
    October 26, 2014
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Alabama
    Year, Model & Trim Level:
    2012 explorer XLT
    i forgot to say that the winshield washer fluid is full
     
  12. Bill #5 Explorer

    Bill #5 Explorer Well-Known Member

    Joined:
    February 9, 2011
    Messages:
    1,103
    Likes Received:
    5
    Trophy Points:
    48
    City, State:
    Chicago Area
    Year, Model & Trim Level:
    2016 Explorer XLT
    Hummmm, Alabama, and it's not frozen, right?
     
  13. bamafan2262

    bamafan2262 New Member

    Joined:
    October 26, 2014
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Alabama
    Year, Model & Trim Level:
    2012 explorer XLT
    It has been cold for here but today in the 50's I don't think so the fluid is supposed to be good for 0
     
  14. Bill #5 Explorer

    Bill #5 Explorer Well-Known Member

    Joined:
    February 9, 2011
    Messages:
    1,103
    Likes Received:
    5
    Trophy Points:
    48
    City, State:
    Chicago Area
    Year, Model & Trim Level:
    2016 Explorer XLT
    Yeah, it's not temperature related, then, at those temps. Roll Tide.
     
  15. NickyB

    NickyB Member

    Joined:
    January 13, 2016
    Messages:
    59
    Media:
    26
    Albums:
    2
    Likes Received:
    18
    Trophy Points:
    18
    City, State:
    Massachusetts
    Year, Model & Trim Level:
    2016 Ford Explorer Sport
    Is it water or a washer fluid? And is it completely full, on all my past SUV's, the front washer will still flow but the rear stops once it falls below half...
     
  16. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    24,400
    Likes Received:
    1,104
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2017 Explorer Platinum
    Callsign:
    VE3
    I merged your thread with this existing one. Are you able to disconnect one of the hoses from its nozzle of from the pump? Try that and see if any fluid comes out. If not, it could be a defective pump. Just because you hear it running doesn't always mean that it's pumping.

    Peter
     
  17. bamafan2262

    bamafan2262 New Member

    Joined:
    October 26, 2014
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Alabama
    Year, Model & Trim Level:
    2012 explorer XLT
    ok ill try that how much is a pump to have put on just to know
     
  18. bamafan2262

    bamafan2262 New Member

    Joined:
    October 26, 2014
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Alabama
    Year, Model & Trim Level:
    2012 explorer XLT
    Is the pump mounted to the Reservoir?
     
  19. peterk9

    peterk9 Staff Member Moderator Elite Explorer

    Joined:
    December 28, 2010
    Messages:
    24,400
    Likes Received:
    1,104
    Trophy Points:
    143
    City, State:
    Ottawa, Ontario area
    Year, Model & Trim Level:
    2017 Explorer Platinum
    Callsign:
    VE3
    Yes. The pump is identified as part 17664.

    Peter
     

    Attached Files:

  20. bamafan2262

    bamafan2262 New Member

    Joined:
    October 26, 2014
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    City, State:
    Alabama
    Year, Model & Trim Level:
    2012 explorer XLT
    Thank you for that peter its a big help
     
  21. NJExplorerFan

    NJExplorerFan Active Member

    Joined:
    May 29, 2009
    Messages:
    335
    Likes Received:
    1
    Trophy Points:
    18
    City, State:
    New Jersey
    Year, Model & Trim Level:
    2015 Limited
    Windshield Washer Fluid Stopped Squirting

    Has anybody had an issue where their windshield washer fluid all of a sudden stopped working? I'm hitting the button and I hear the motor going but the driver's side squirts NOTHING and the passenger side squirts out just a pinch to only cover the bottom 1/4 of the windshield. At first I thought it was frozen from the cold weather but it's been much warmer and still I'm having the same issue. It doesn't appear to be dirty from anything. Is it worth sticking a toothpick in the hole to "clear it out" or is it time for Ford Service?
     

Share This Page







We Support Our Troops!