Dismiss Notice



Register Today It's free! This box will disappear once registered!

wtf now

Discussion in 'Stock 2002 - 2005 Explorers' started by lynnboy021, July 25, 2011.

  • Searches ExplorerForum.com
    1. lynnboy021

      lynnboy021 Active Member

      Joined:
      January 17, 2010
      Messages:
      150
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      billerica ma
      Year, Model & Trim Level:
      2002 xlt
      02 4.0 i took off my tb out to clean it and i put it back and now i get high rpm. the mil came on and it said my tps is to low i think it was code p0122 i think. and yes i made sure nothing was out or lose.
       
    2. Support EF

      Join the Elite Explorers for $20

      Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no ads, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create more private Conversations, and more. Join Today. Your support is greatly appreciated.


      to hide adverts.
    3. Black Dynomite

      Black Dynomite Active Member

      Joined:
      October 5, 2009
      Messages:
      270
      Likes Received:
      2
      Trophy Points:
      18
      City, State:
      Wellington, New Zealand
      Year, Model & Trim Level:
      2005 Ltd 4.6L
      Did you disconnect the neg battery cable when you did this? Maybe the PCM needs to relearn the correct idle.
       
    4. lynnboy021

      lynnboy021 Active Member

      Joined:
      January 17, 2010
      Messages:
      150
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      billerica ma
      Year, Model & Trim Level:
      2002 xlt
      no i did not. but i did not start the truck or anything without plugging it
       
    5. BrianDye

      BrianDye I'll have another...

      Joined:
      March 1, 2009
      Messages:
      6,224
      Likes Received:
      8
      Trophy Points:
      48
      City, State:
      Monroe, MI
      Year, Model & Trim Level:
      2006 XLT
      Disconnect one of the battery terminals for about 5-10 minutes. It will clear the codes and clear the computer out.

      I did that when I cleaned mine, and it was so dirty that when I went to start it, it cranked for about 5-6 seconds before it finally started.
       
    6. lynnboy021

      lynnboy021 Active Member

      Joined:
      January 17, 2010
      Messages:
      150
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      billerica ma
      Year, Model & Trim Level:
      2002 xlt
      so when i do that it should put my idle back?
       
    7. lynnboy021

      lynnboy021 Active Member

      Joined:
      January 17, 2010
      Messages:
      150
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      billerica ma
      Year, Model & Trim Level:
      2002 xlt
      so i did what u said but my idle is still high do i have to drive it more?
       
    8. Black Dynomite

      Black Dynomite Active Member

      Joined:
      October 5, 2009
      Messages:
      270
      Likes Received:
      2
      Trophy Points:
      18
      City, State:
      Wellington, New Zealand
      Year, Model & Trim Level:
      2005 Ltd 4.6L
      how many rpms?
       
    9. lynnboy021

      lynnboy021 Active Member

      Joined:
      January 17, 2010
      Messages:
      150
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      billerica ma
      Year, Model & Trim Level:
      2002 xlt
      1 to 1 1/2 and i had my tranny rebuilt so its not helping me out. when the tranny wants to down shift it kicks cuz of the rpm and when i am holding the brakes and let go the truck can go up a hill with no gas lol. also my truck will only go to 40 mph and u can let go or floor the gas it wont do anything but if you hold the gas then u can go over 40. mil code just said tps is low but i did not touch it.... should i just drive it
       
    10. sethmorgan

      sethmorgan Active Member

      Joined:
      January 11, 2008
      Messages:
      206
      Likes Received:
      1
      Trophy Points:
      0
      City, State:
      Hanahan, SC
      Year, Model & Trim Level:
      2002 XLT 4.0
    11. Javadog123

      Javadog123 Member

      Joined:
      July 18, 2011
      Messages:
      81
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      Hilo ,Hawaii
      Year, Model & Trim Level:
      2004 XLS AWD
      Sorry, not up to speed on Exploreres yet, but a lot of cars that I've worked on it was possible to adjust the tps. You would loosen the screws (3) on the other cars and turn until the specs were met. If I can find time today I will check the manual, but I find the ford shop manual is a little difficult to find stuff in so we will see...
       
    12. fedyfedz

      fedyfedz Active Member

      Joined:
      April 26, 2010
      Messages:
      898
      Likes Received:
      2
      Trophy Points:
      16
      City, State:
      Suffolk County, NY
      Year, Model & Trim Level:
      2002 limited v8
      check to make sure the slack is the same on the throttle body wire and make sure that when truck is off the valve is closed all the way, when i put my aftermaket one on the gas pedal went down to the floor casue the spacing was slightly off with the aftermaket one so i had to tighten. Im assuming your problem is opposite that you made the wire to tight. just my 2 cents
       
    13. Black Dynomite

      Black Dynomite Active Member

      Joined:
      October 5, 2009
      Messages:
      270
      Likes Received:
      2
      Trophy Points:
      18
      City, State:
      Wellington, New Zealand
      Year, Model & Trim Level:
      2005 Ltd 4.6L
      Also, make sure you dont have a vacumn leak. Did you use a new gasket and clean the mating surfaces when you reinstalled the TB?
       
    14. lynnboy021

      lynnboy021 Active Member

      Joined:
      January 17, 2010
      Messages:
      150
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      billerica ma
      Year, Model & Trim Level:
      2002 xlt
      autozone said that the tb is not ment to be cleaned with anything kind of spary is that right cuz you can wipe off the paint or something?????
       
    15. Black Dynomite

      Black Dynomite Active Member

      Joined:
      October 5, 2009
      Messages:
      270
      Likes Received:
      2
      Trophy Points:
      18
      City, State:
      Wellington, New Zealand
      Year, Model & Trim Level:
      2005 Ltd 4.6L
      Yeah Haynes manual etc say the same thing. Some on here say its ok, and supposedly the worst it can do is give your intake a whistle.
      Never did find out what that special coating was for. Anyone?
       
    16. lynnboy021

      lynnboy021 Active Member

      Joined:
      January 17, 2010
      Messages:
      150
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      billerica ma
      Year, Model & Trim Level:
      2002 xlt
      what i will do is tomorrow i will just go to the junk yard and take a tps....
       
    17. lynnboy021

      lynnboy021 Active Member

      Joined:
      January 17, 2010
      Messages:
      150
      Likes Received:
      0
      Trophy Points:
      0
      City, State:
      billerica ma
      Year, Model & Trim Level:
      2002 xlt
      so i went to the junkyard yesterday and got a new tps and everything works fine... how the old tps broke, i have no clue but thanks guys
       

    Share This Page







    We Support Our Troops!