• Register Today It's free! This box and some ads will disappear once registered!

Oil coming up from oil pump shaft?
08EddieCA

Oil coming up from oil pump shaft?

There is no oil running down the heads. No hg leak. It’s coming up from the oil pump thing. The o- ring must be bad. I’ve cleaned it a dozen times.
 
08EddieCA Rebuilt motor. New head gaskets. New uppoer intake manifold gaskets (changed twice for good measure). Cleaned that part of the galley a few times. Oil keeps appearing. Only thing I can think of is the oil is coming up through the oil pump screw. Might need a new gasket. My problem starts with the oil pump screw being timed. Or, the nut holding the part in place wasnt tapped down to the bottom and hydrolocked before the hole could be cleaned - hence the hold isn't tightened all the way down.
 
Still leaking. So far I’m at a loss as to the source. Could be coming up from the small plug between the freeze plug pictured and the oil pump drive. I haven’t found any info on what, if anything, that small plug does or holds or anything. I might look at the pcv grommet too. Heads are good. I like to use copper spray on my head gaskets. It’s possible there’s a leak from the side of the head. That would suck big time.
 

Media information

Category
3rd and 4th Generation Ford Explorer Gallery
Added by
08EddieCA
Date added
View count
369
Comment count
3
Rating
0.00 star(s) 0 ratings

Image metadata

Device
Apple iPhone 6 Plus
Aperture
ƒ/2.2
Focal length
4.2 mm
Exposure time
1/15
ISO
320
Flash
Auto, did not fire
Filename
B59D03FB-0B3D-487A-8B38-CC2ED1F22251.jpeg
File size
420.2 KB
Date taken
Sat, 23 February 2019 3:20 PM
Dimensions
1014px x 1352px

Share this media

Top