Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!
    If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Search results

  1. M

    Rough Idle and Noise from Intake(?)

    Hi Everyone. I’ve got a 1993 Explorer XLT that has developed a strange noise under the hood and a rough idle. In the last week I’ve noticed that it seems harder to start, and idle seems to be quite rough. A couple of times it has died while idling. As of today it is stumbling so much at idle...
  2. M

    4x4 Shift Motor Rebuild Issues - Sealant

    Hello everyone. I started a shift motor rebuild last night and ran into an issue and was looking for advice. I got the shift motor uninstalled pretty easily. I ran into one issue where I did not see the word push on the connector tabs, and spent quite a while trying to pry them up. Once I...
  3. M

    Rear Leaf Questions

    I’m looking for some advice on how to proceed with the rear springs on my explorer. A while back I looked underneath and noticed on the driver’s side, the back half of the 2nd leaf broke off and is no longer there. Both the driver’s and passenger springs are very rusty. The shackles are also...
  4. M

    Broken brake line - empty reservoir

    The other day I was getting off the interstate, and when I went to brake the pedal went all the way to the floor. I got out and checked and found a puddle of brake fluid under the rear driver's side wheel. I was able to top off the MBC and limp home. I took it in to the shop the next day...
  5. M

    Overflow tank empty

    Hey Everyone, I received my explorer from my dad about a year a go now. The other day I was filling the wiper fluid, and decided to look at the coolant as well. I checked the overflow tank and it was bone dry. I always thought it had coolant before but I believe it was just stained. At first...
  6. M

    Tranny flush and secondary filter

    I've been trying to catch up all on the preventive maintenance on my explorer and after reading on here the next thing in line is the tranny. As far as I know the tranny oil/ filter has never been changed. My family got the explorer from my grandma with 35-40k. It hasn’t been changed since we...
  7. M

    Limited Slip help

    Hello All, I’ve been doing lots of research on my explorer, and I recently discovered it has a limited slip rear end. As far as I can tell it’s not working. I’ve never felt it “hook up” before. I did some searches here and one of the ways to test it is to jack up both rear tires and with the...
  8. M

    4x4 won't engage when cold

    Hello All, I've been working on fixing all the little glitches my explorer has, and with summer ending I'm thinking I should address the 4 wheel drive. I've went through the 4x4 troubleshooting thread, but it doesn't directly address my issue. I've only had my explorer for 8 months now, but...
  9. M

    Front end suspension noises?

    Hi All, I’m hoping you can help me diagnose the problem I’m having in my front end that I’m having a hard time with. I don't think it’s too complicated, I just don’t have a lot of experience with these. I've got a 93 explorer xlt with 109,000. I've got a few odd noises coming from the front...
  10. M

    Not sure what to check - Codes 181, 185, 186

    Hello Everyone, I have a 92 explorer with 108,000 miles, and I’m having some problems but I’m not sure where to start. I’m not sure if these three problems are related or not, so hopefully someone can point me in the right direction. 1. First, and most prominent, happens everytime I start...
Top