Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Search results

  1. I

    No dashlights, no radio....

    My heater core went bad. The floor is all wet under the passenger side carpet. So I bypassed the heater core for now. But at about the same time I noticed the wet floor, my dashlights and radio stopped working. I checked all the fuses under the steering wheel; they were fine. I checked all the...
  2. I

    aftermarket amp and sub help

    What wire can I hook the remote on wire from the amp to? I've read of guys wiring it to something with the ignition so the amp is on when the key is in accessory. I tried wiring the amp to the blue power antenna wire in the radio harness but that didn't cause the amp to turn on. I am confident I...
  3. I

    clutch/transmission enigma

    the day after a 170 mile drive home, i started my truck and let it run for a lil before i set off. the clutch pedal went in like usual, started the truck with the gear shift in neutral, and went inside for 2 mins. came back out, couldn't get the tranny in gear, was grinding gears. the clutch...
  4. I

    unidentifiable vibration

    My truck sat for about a week and a half, the same time it started to get consitently cold outside (state college, pa). drove around after this slump and noticed a vibration shaking the whole cabin when i was in 4th. this vibration got progressively worse and has peaked in intensity now, about...
  5. I

    1991 oil leak

    My XLT is leaking oil somehow, someway. I changed the oil and filter about a month and half ago. a few days ago the check oil light came on and i had to put a liter and half in. i also changed the drain plug. so i dont know where else it will be leaking from. buddy of mine checked out the seals...
Top